Opened 2 years ago

Closed 12 months ago

#13591 closed defect (fixed)

AGS: Achievements explicitly disabled for Heroine's Quest?

Reported by: Crystal-Shard Owned by: tag2015
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Crystal-Shard Game:

Description (last modified by Crystal-Shard)

In the file https://github.com/scummvm/scummvm/blob/master/engines/ags/plugins/ags_galaxy_steam/ags_galaxy_steam.cpp#L111
the function AGS2Client::get_Initialized explicitly returns false if the current game is either "heroinesquest" or "killyourself".

It says this is because GetCurrentGameLanguage doesn't work, but achievements are not dependent on game language. Expected behavior would to default to English, not to disable the achievement functions.

Please note, I'm the developer for Heroine's Quest so I can answer questions from that end if needed.

Change History (5)

comment:1 by Crystal-Shard, 2 years ago

Description: modified (diff)

comment:2 by Crystal-Shard, 2 years ago

A likely solution:

https://github.com/scummvm/scummvm/blob/master/engines/ags/plugins/ags_galaxy_steam/ags_galaxy_steam.cpp#L159
has a stub for AGS2Client::GetCurrentGameLanguage().

What this function should do, is call AchievementsManager::getCurrentLang() from https://github.com/scummvm/scummvm/blob/master/common/achievements.cpp#L86

comment:3 by aquadran, 21 months ago

Summary: Achievements explicitly disabled for Heroine's Quest?AGS: Achievements explicitly disabled for Heroine's Quest?

comment:4 by tag2015, 12 months ago

Should be fixed in commit 42b9255

comment:5 by tag2015, 12 months ago

Owner: set to tag2015
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.