Opened 2 months ago

Closed 2 months ago

#13563 closed defect (duplicate)

COMMON: "No icons path set" error despite icons path being set

Reported by: Thunderforge Owned by: antoniou79
Priority: high Component: Common
Version: Keywords:
Cc: Game:

Description (last modified by Thunderforge)

With the 2.6.0 pre-release build, it is impossible to download icons due to "No icons path set" error, even if the icons path is set.

This has been tested on both macOS and Windows.

Reproduction Steps

  1. In the Launcher, click "Global Options..."
  2. Click the "Paths" tab
  3. Under "Icons Path", select a path
    • If it matters, I chose an empty folder
  4. Click "Apply"
  5. Click the "Misc" tab
  6. Click "Update Icons"

The result will be the error message "No icons path set".

Additional Info

The log file does not provide any information at all.

See attached animated gif demonstrating this behavior.

Versions Tested

  • ScummVM 2.6.0 pre-release 2022-06-10
  • macOS 12.4
  • Windows 11 22H1

Attachments (1)

No Icon Path.gif (84.0 KB ) - added by Thunderforge 2 months ago.

Download all attachments as: .zip

Change History (6)

by Thunderforge, 2 months ago

Attachment: No Icon Path.gif added

comment:1 by Thunderforge, 2 months ago

Description: modified (diff)

comment:2 by Thunderforge, 2 months ago

Description: modified (diff)
Summary: COMMON: "No icons path set" error on Windows despite icons path being setCOMMON: "No icons path set" error despite icons path being set

comment:3 by Thunderforge, 2 months ago

Looking into the code a bit, I think the problem is that the GUI dialog sets iconpath (singular) and the downloader gets iconspath (plural).

We should pick one or the other and stick to it throughout the codebase.

comment:4 by antoniou79, 2 months ago

This seems to be a duplicate of https://bugs.scummvm.org/ticket/13556

The PR with the fix was merged a few hours ago, and it is now backported to branch-2-6

Please check if the issue persists.

comment:5 by Thunderforge, 2 months ago

Owner: set to antoniou79
Resolution: duplicate
Status: newclosed

Confirmed that this is now fixed.

Note: See TracTickets for help on using tickets.