Opened 3 weeks ago

Closed 10 days ago

#13562 closed defect (fixed)

AGS: Blackwell Unbound crash early in the game (regression)

Reported by: tag2015 Owned by: criezy
Priority: normal Component: Engine: AGS
Version: Keywords: ags blackwell
Cc: Game:

Description

Using ScummVM 2.6.0pre26 or master, Blackwell Unbound crashes early in the game during the first "case". It works properly in version 2.5.1.

Steps to reproduce

  • Make sure Joey is selected
  • Click on the gate
  • Let the cutscene play. ScummVM freezes or segfaults after the purple ghost says her line

This is a scummvm only bug, it does not occur using a recent release of the ags interpreter.

Win10, latest GOG release

Attachments (1)

blackwell2.005 (128.7 KB ) - added by tag2015 3 weeks ago.

Download all attachments as: .zip

Change History (3)

by tag2015, 3 weeks ago

Attachment: blackwell2.005 added

comment:1 by antoniou79, 11 days ago

This seems to have been fixed in the recent commits in the development (master) branch. I cannot reproduce the issue with development build 2.7.0git (built from master HEAD today).

The issue does still persist in the 2.6.0 release candidate stable branch as of yet.

comment:2 by criezy, 10 days ago

Owner: set to criezy
Resolution: fixed
Status: newclosed

This was likely an issue in upstream AGS at some point as well. I have been merging various commits from upstream in master over the last two weeks to catch up with their current code.

I have now merged a selection of those in the 2.6 branch as well, and it seems to have fixed the crash there.

Note: See TracTickets for help on using tickets.