Opened 2 years ago

Closed 8 months ago

#13545 closed defect (fixed)

GUI: Many games are not listed in series group

Reported by: windlepoons Owned by: sev-
Priority: normal Component: GUI
Version: Keywords: Series
Cc: Game:

Description

Currently, some games are not shown as part of a series in the series selection, or the series is missing completely

Series with missing games (is not in a series):
EcoQuest:
EcoQuest II

Broken Sword:
Broken Sword 2.5 (fan game)

Goblins:
Gobliins 2
Goblins 3

King’s Quest:
King's Quest II
King's Quest III
King's Quest IV
King's Quest V
King's Quest VI

Leisure Suit Larry:
Larry 1
Larry 2
Larry 5
Larry 6

Zork:
Zork I
Zork II
Zork III
Beyond Zork
Zork: The Undiscovered Underground
Return to Zork
Zork: Grand Inquisitor

Missing series (the related games are unsorted):
Gabriel Knight
Goblins
Laura Bow
Police Quest
Quest for Glory
Space Quest

PS: The engine sorting is broken, many games are listed as unknown engine.

Testing mainly with german games
ScummVM 2.6.0git6171-gf93e757aff2 (May 30 2022 04:12:52)

Change History (5)

comment:1 by tag2015, 22 months ago

Can't reproduce, could you please try version 2.6.0 or a recent development version and see if the situation improved?

in reply to:  1 comment:2 by windlepoons, 22 months ago

Replying to tag2015:

Can't reproduce, could you please try version 2.6.0 or a recent development version and see if the situation improved?

Currently ScummVM shows many Sierra games under SIERRA NO SERIES (King's Quest, LSL, PQ)
If I go to Game Options for e.g. PQ1, then OK without change, PQ1 is now in POLICE QUEST series.
Same with Kings Quest V → KINGS QUEST series, Zork. Goblins has no series at all.
Why is there no automatic matching into correct series?

Maybe not all old id entries were taken over with the introduction of the series?

ScummVM 2.7.0git3088-ge70c103ca37 (Oct 2 2022 04:08:09)

comment:3 by i30817, 22 months ago

It's not unusual for a game id to change between releases of scummvm (eg: from 'generic engine name' to 'actual game name'), so if you're keeping old scummvm.ini to test this, you'll probably get false positives of the reported bug.

comment:4 by tag2015, 13 months ago

Summary: Many games are not listed in series groupGUI: Many games are not listed in series group

comment:5 by sev-, 8 months ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

I just re-checked and all the mentioned games have series attached in the latest icons pack.

Note: See TracTickets for help on using tickets.