Opened 2 years ago

Closed 13 days ago

#13532 closed defect (fixed)

SCUMM/HE: Flashing line at bottom of screen in Freddi 3

Reported by: Thunderforge Owned by: AndywinXp
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Freddi Fish 3

Description (last modified by Thunderforge)

In Freddi Fish 3: The Case of the Stolen Conch Shell, there is a situation in which a flashing line appears at the bottom of screen during some dialogue.

Reproduction Steps

  1. Open the debugger and type in room 17
  2. Click on the pink fish on the rope in the upper left corner of the screen (do not click on the clam to cut the rope)
  3. Luther will say "Gee, that fish looks like it's really hungry for those kelp vines."

During Luther's dialogue, the very bottom of the sreen will have a flashing line. See attached animated GIF

Versions tested

  • Freddi Fish 3: Steam release
  • ScummVM 2.6.0 nightly 2022-06-02

Attachments (1)

Room 17.gif (551.0 KB ) - added by Thunderforge 2 years ago.

Download all attachments as: .zip

Change History (6)

by Thunderforge, 2 years ago

Attachment: Room 17.gif added

comment:1 by Thunderforge, 2 years ago

Description: modified (diff)

comment:2 by Thunderforge, 2 years ago

Turns out this *doesn't* happen in the English-UK version of the game, but it does in the English-US version.

comment:3 by AndywinXp, 10 months ago

I have verified that this happens in the original executable too. It's probably a corrupt data file (maybe one of Luther's lipsync frames?).

Please mark it as enhancement when fixing it!

comment:4 by AndywinXp, 13 days ago

In 59f752c0:

SCUMM: HE/FREDDI3: Provide better solution for bug #13532

"SCUMM/HE: Flashing line at bottom of screen in Freddi 3"

This solves #13532 in a better way: instead of moving the
animation down by one pixel, we simply avoid marking that
line of stray pixels as part of the dirty rectangle.

We remove two pixels since AkosRenderer::paintCelByleRLE()
is going to add one pixel to the rect during the clipping part.

comment:5 by AndywinXp, 13 days ago

Owner: set to AndywinXp
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.