Opened 8 months ago

Closed 8 months ago

#13525 closed defect (fixed)

GUI: Game list no longer responds to key presses (recent regression)

Reported by: sluicebox Owned by: sev-
Priority: high Component: GUI
Version: Keywords:
Cc: Game:

Description

On the launcher in list mode, pressing a letter key no longer selects the first game that starts with that letter.

This was introduced a few days ago in commit "GUI: Initial code for embedding formatting info into *ListWidget strings" - https://github.com/scummvm/scummvm/commit/3727b3e16ed4ac690b0f279975b1badc2da48e97

This commit might have been a fix for #13096 but I'm not sure.

I'm creating a new ticket for this to ensure visibility since we're so close to the 2.6.0 release. I have a ton of versions of games and jump around a lot to test things; I desperately rely on this feature!

Change History (1)

comment:1 by sev-, 8 months ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

Fixed.

Note: See TracTickets for help on using tickets.