Opened 8 months ago

Closed 8 months ago

#13524 closed defect (fixed)

Chewy - German Version . Crash after Intro when the the game starts

Reported by: gabberhead Owned by: bluegr
Priority: normal Component: Engine: Chewy
Version: Keywords:
Cc: Game: Chewy: ESC from F5

Description

Intro plays fine. but when the game starts, the game crashes with following error:

Assertion failed: idx < _size, file /data/src/common/array.h, line 232

Change History (6)

comment:1 by lephilousophe, 8 months ago

Component: --Unset--Engine: Chewy

comment:2 by gabberhead, 8 months ago

with the newest daily build from 8.6. the game don't crash right after intro anymore. now when i skip the intro, it goes to the menu. before that, when i skipped the intro, it went straight to the game and crashed right after this. now, like i wrote, the crash right after the game starts is gone, but in the game after ca. 1-2minutes, the game crashes to desktop without a error message. tried it 4 times, and always crashed after the same time between 1-2 minutes in the game. in the log, there is no error message.

comment:3 by DarkCloud14, 8 months ago

Interesting, for me th game still goes directly into the game instead of the menu when skipping the intro. I have tested it with the current daily build 2.6.0pre26-gdac4ba3e1d9 on macOS 12.4.

I could avoid the crash after 1 - 2 minutes by adjusting the audio options of the game in ScummVM.
When I override global audio settings and set "Text and speech" to Subtitles or both ScummVM doesn't crash anymore, setting it to Speech crashes ScummVM again.
This also fixes a crash for me regarding the intro sequence, see ticket #13539

I think after 1-2 minutes the feeding cutscene would start and that crashes the game at least for me when the "Text and Speech" setting is set to Speech.

comment:4 by gabberhead, 8 months ago

i am using the newst daily builds 2.7.0 not the stable release testing 2.6.0 builds

comment:5 by gabberhead, 8 months ago

i can confirm, if i set to text and speech, the game don't crash after 1-2 minutes in the game. but i can not go back to speech only. when i switch back to speech only in the scummvm game menu and go in the game, the text is also there. it activates the text again automaticly. and in the game menu in scummvm, text and speech is again selected.
the next problem is, but i think this is already known, there are no german, for example, ÄÖÜ letters in the german verrsion of the game.

comment:6 by bluegr, 8 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

The crash was caused by the text handling code, which was trying to access uninitialized memory.

Playing with speech only should be working now. Please check with a daily ScummVM version

Note: See TracTickets for help on using tickets.