Opened 8 months ago

Closed 7 months ago

Last modified 7 months ago

#13523 closed defect (fixed)

CHEWY: Missing secondary comments by Chewy

Reported by: afreickmann Owned by: bluegr
Priority: normal Component: Engine: Chewy
Version: Keywords:
Cc: Game: Chewy: ESC from F5

Description

Many of Chewys comments are missing, when you try something not working. Most obvious it is on F5 with the Access card. In the Original, he says "Access denied", in the ScummVM version he says "I cant do that".
Another example is the face scanner: You get for the alien mask and the alien mouse two unique comments. I assume its more often happening.

Attachments (1)

chewy.067 (19.5 KB ) - added by dreammaster 8 months ago.

Download all attachments as: .zip

Change History (11)

comment:1 by afreickmann, 8 months ago

Another good area where you can notice it is at the dumpster factory. The monitor here can show different items and Chewy will react to each of it individual. In the ScummVM version, he just gives the answer for the black screen.

comment:2 by afreickmann, 8 months ago

Another alternative text example is the book in Howards room, you can go through his whole book - title + 6 chapters.

by dreammaster, 8 months ago

Attachment: chewy.067 added

comment:3 by dreammaster, 8 months ago

Summary: Chewy: Missing "You cant do this dialog"CHEWY: Missing "You cant do this dialog"

The culprit seems to be:

commit 8eadac5eeda901f5a81766b86c4a87b86a143ebf
Author: Filippos Karapetis <bluegr@…>
Date: Sat Apr 16 05:16:58 2022 +0300

CHEWY: Refactor handling of scene text

I'm attaching a savegame from the trash room. If you look at the monitor it says "Looks like Paris by night". If you then push the button to change the image, it's meant to give different look respoinses.

comment:4 by afreickmann, 7 months ago

Summary: CHEWY: Missing "You cant do this dialog"CHEWY: Missing secondary comments by Chewy

The issue is especially problematic when manipulating the fake artifact in Amazonia. Chewy says, the scratching does not work, the comment does not change and also the comment after the scratching is same. Thus, this puzzle is impossible to solve for new players.

comment:5 by afreickmann, 7 months ago

Priority: normalhigh

comment:6 by afreickmann, 7 months ago

Noticed problematic scenes all through the game, you are missing many hints by Chewy, making the game definitely worse as it is. The game is far from perfect, but here the developers did some wise choices and gave many tips.

comment:7 by bluegr, 7 months ago

Priority: highnormal

Lowering priority to normal. This is not a game breaking bug

comment:8 by bluegr, 7 months ago

Finally fixed that one in the following commit:
https://github.com/scummvm/scummvm/commit/ae3ebc5b02f707828068e488d044c1608cebfa61
This will be fixed in the latest unstable version. Will need to check if it can be backported to version 2.6.0

comment:9 by bluegr, 7 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:10 by bluegr, 7 months ago

This fix has also been backported to version 2.6.0

Note: See TracTickets for help on using tickets.