Opened 5 weeks ago

Closed 5 weeks ago

Last modified 5 weeks ago

#13501 closed defect (fixed)

LSL6 Hi-Res: Canceling narrator doesn't cancel Daryl waiting to press button

Reported by: RayKoopa Owned by: sluicebox
Priority: low Component: Engine: SCI
Version: Keywords: original
Cc: RayKoopa Game: Leisure Suit Larry 6

Description

  • ScummVM 2.6.0git5957-ga933a0d261c (May 23 2022 02:04:07)
  • Game language: English
  • Game version: Hi-Res 1.000.000
  • Windows 11 21H2 10.0.22000.675

Steps to reproduce:

  • Go to the gate house in front of the hotel.
  • Use the "Take" action on the handcuffs, pistol, or pocket on Daryl's belt.
  • Cancel the narrator saying "Without thinking twice..."
  • Notice how Daryl still waits to press the button as if waiting for the narrator to end his sentence.

This does not happen in the lo-res version of the game.
It also does not happen in the hi-res version in DOSBox.

Attachments (1)

lsl6hires.001 (40.4 KB ) - added by RayKoopa 5 weeks ago.

Download all attachments as: .zip

Change History (5)

by RayKoopa, 5 weeks ago

Attachment: lsl6hires.001 added

comment:1 by sluicebox, 5 weeks ago

Another great catch! This is a weird script that calculates a delay that's way too long (30+ seconds) because of the way scummvm handles speed tests and speed throttling. It's the only script that does anything like this, so we can just patch it to something reasonable. It's just a backup delay that gets used if you dismiss the message quickly, like within the first two seconds.

comment:2 by RayKoopa, 5 weeks ago

Yes, I can confirm that there is no delay when canceling Neil Ross _after_ 2 seconds. Daryl has moved his finger up by then, so maybe they attempted to do some minimal wait here for players to see his finger animation properly?

Last edited 5 weeks ago by RayKoopa (previous) (diff)

comment:3 by sluicebox, 5 weeks ago

Keywords: original added
Owner: set to sluicebox
Resolution: fixed
Status: newclosed

Fixed in: https://github.com/scummvm/scummvm/commit/1c2e1bc54fe661c442fe6b91297c6aa25c0541fa

The delay when dismissing the message early is now consistent and unaffected by the speed test. Thanks for reporting!

comment:4 by RayKoopa, 5 weeks ago

Thanks! Can confirm it's fixed :D

Note: See TracTickets for help on using tickets.