Opened 5 weeks ago

Closed 5 weeks ago

Last modified 5 weeks ago

#13500 closed defect (fixed)

LSL6 Hi-Res: Rocket death dialog not read aloud

Reported by: RayKoopa Owned by: sluicebox
Priority: low Component: Engine: SCI
Version: Keywords:
Cc: RayKoopa Game: Leisure Suit Larry 6

Description

  • ScummVM 2.6.0git5957-ga933a0d261c (May 23 2022 02:04:07)
  • Game language: English
  • Game version: Hi-Res 1.000.000
  • Windows 11 21H2 10.0.22000.675

Steps to reproduce:

  • Go to the gate house in front of the hotel.
  • Use the "Take" action on the handcuffs, pistol, or pocket on Daryl's belt.
  • Wait for Daryl to launch the rocket on you, and it crashing with you into the ocean.
  • Note how the text in the death dialog ("Could a missile up your butt be considered brutality? NAH!") is _not_ read aloud by the narrator.

In DOSBox, the dialog is read aloud. Other dialogs do not have this problem.

This issue does not affect the lo-res game as it apparently never reads death dialog aloud, even when installing it from the hi-res talkie CD version (also confirmed in DOSBox).

Attachments (1)

lsl6hires.001 (40.4 KB ) - added by RayKoopa 5 weeks ago.

Download all attachments as: .zip

Change History (7)

by RayKoopa, 5 weeks ago

Attachment: lsl6hires.001 added

comment:1 by sluicebox, 5 weeks ago

Interesting... the death-dialog script is programmed to check for Daryl's messages and skip playing audio on both of them. Those are the only messages it checks for. I don't know why they did that, but I'm more interested in how it's possible that this audio ever plays in dosbox.

The messages do play in at least some youtube videos: https://www.youtube.com/watch?v=dQ9398qFfRY (at the very end)

It seems like this must be a version difference; some have this check and some don't? Are you able to get audio yourself in dosbox? And if so, can you confirm that pointing scummvm at those exact same files still gets no audio? Warning: if the answer to both of those questions are Yes then that doesn't add up and I'm going to have a lot of follow-up questions! =)

Ultimately, if it turns out that there's no problem with playing these message audios we can patch out the skip, but first we have to figure out what's going on.

comment:2 by RayKoopa, 5 weeks ago

Yes, I get the audio in DOSBox, which is the first comparison I made.

However, since I installed the game in DOSBox through the Sierra setup on the CD, and for ScummVM I copied together the files as stated on the wiki, I get no sounds or voice at all in ScummVM if I use the DOSBox installation directory in it (since they are supposed to be on the "CD", and ScummVM warns me about some missing files, logically). Would you like me to set up these comparisons differently?

comment:3 by sluicebox, 5 weeks ago

Thanks, I've got it running in dosbox now and I see what's going on. There's some subtle audio initialization behavior this script depends on that we're not doing. I tried adding it and it fixed it. I'll have to do some more research on this, but it should be done in the near future.

comment:4 by RayKoopa, 5 weeks ago

"Sounds" great! Let me know when there's a commit / version in which it's fixed so I can test and play with it :)

comment:5 by sluicebox, 5 weeks ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed

comment:6 by RayKoopa, 5 weeks ago

Thanks! Can confirm it's fixed :D

Note: See TracTickets for help on using tickets.