Opened 4 months ago

Closed 6 weeks ago

#13491 closed defect (fixed)

HYPNO: Unknown game variant for hypno - GOG Wetlands

Reported by: enderandrew Owned by: neuromancer
Priority: normal Component: Engine: Hypno
Version: Keywords: unknown-game
Cc: Game:

Description

ScummVM 2.6.0git5836-g6b0dcc761de (May 18 2022 04:48:35)
Features compiled in: TAINTED Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora AAC A/52 FreeType2 FriBiDi JPEG PNG GIF taskbar TTS cloud (servers, local) TinyGL OpenGL (with shaders)

The game in 'wetlands\' seems to be an unknown game variant.

Please report the following data to the ScummVM team at https://bugs.scummvm.org/ along with the name of the game you tried to add and its version, language, etc.:

Matched game IDs for the hypno engine: wetlands-demo-us

{"missions.lib", 0, "aeaaa8b26ab17e37f060334a311a3ff6", 309793},
{"wetlands.exe", 0, "15a6b1b3819ef002438df340509b5373", 647411},

Change History (6)

comment:1 by neuromancer, 4 months ago

Hi,

Thanks a lot for your submission. I will add this new version very soon. I just need a description of the release (e.g. language, year, edition, etc) and if it is possible, where you got it.

Thanks!

comment:2 by enderandrew, 4 months ago

Should be English. I extracted the files from Wetlands.iso in the GOG version.

https://imgur.com/a/YLzCtuc

comment:3 by neuromancer, 4 months ago

Uhm, I have the same version but I cannot reproduce it. How exactly you extracted the files from iso? I can only see the installed files as well as the iso in that picture.

In other words, can you show a picture of the directory where you extracted the files?

comment:4 by neuromancer, 4 months ago

Hey, any update on this ticket? The 2.6.0 release is coming "soon" and it could be awesome to be able to close this ticket adding a new variant, if necessary.

comment:5 by aquadran, 4 months ago

Summary: Unknown game variant for hypno - GOG WetlandsHYPNO: Unknown game variant for hypno - GOG Wetlands

comment:6 by neuromancer, 6 weeks ago

Resolution: fixed
Status: newclosed

It seems that this was Wetlands with the 1.1 patch applied. This is not necessary to run the game, but in any case, I fixed it to correctly detect it here: https://github.com/scummvm/scummvm/commit/3e1217159ff991623585be4eba2cb3a822e79f0f

Thanks for the report!

Note: See TracTickets for help on using tickets.