Opened 6 weeks ago

Closed 5 weeks ago

Last modified 5 weeks ago

#13490 closed defect (fixed)

Lands of Lore: The Throne of Chaos: Unknown game variant for kyra

Reported by: Blood138 Owned by: athrxx
Priority: normal Component: Engine: Kyra
Version: Keywords: unknown-game
Cc: Game:

Description

ScummVM version: ScummVM 2.5.1

Game language: Spanish

Game version: DOS Floppy

WESTWOOD.* files from the spanish version of floppy disk are not detected.

The game in 'Lands1\' seems to be an unknown game variant.

Matched game IDs for the kyra engine: lol

{"WESTWOOD.1", 0, "6c99a3e6b904cc9e8c026061305309de", 1326593},

I also have some issues with the extracted/DOS/Spanish version.

  1. When I try to load the game after the first time I get an error message that says: "Error running game: Game data not found"
  1. It crashes when attempting to remap controls "in-game"

Attachments (3)

scummvm_1.log (848 bytes ) - added by Blood138 6 weeks ago.
scummvm_2.log (1.1 KB ) - added by Blood138 6 weeks ago.
scummvm.Error.log (19.0 KB ) - added by Blood138 5 weeks ago.

Download all attachments as: .zip

Change History (23)

by Blood138, 6 weeks ago

Attachment: scummvm_1.log added

by Blood138, 6 weeks ago

Attachment: scummvm_2.log added

comment:1 by Blood138, 6 weeks ago

Summary: Unknown game variant for kyraLands of Lore: The Throne of Chaos: Unknown game variant for kyra

comment:2 by athrxx, 6 weeks ago

It seems that I added the Spanish floppy detection "blindly" without actually having that game.
I have now also added the entry for the installer package blindly, just from the numbers you provided.

Since it doesn't work, I presume it is a fan translation and doesn't find the correct language files. Unfortunately these are contained in those PAK files, so you can't just tell me which file extensions these have...

Do you happen to know whether it is a fan translation or an official one? (an indication for an official version would be if you have the intro speech in Spanish)

comment:3 by Blood138, 6 weeks ago

Hello, the floppy version was the only one officially translated into Spanish. I have an original physical copy.

https://postimg.cc/YGpw2zgk

http://www.goodolddays.net/diskimages/id%2C1654/

comment:4 by athrxx, 6 weeks ago

Okay thanks for confirming, so this is not the reason for the error message then.

What do you mean by "load the game after the first time"? Is it the first time after detection where the game actually works? And no more after that?

Does the newly added installer package (Westwood.*) support work for you?

comment:5 by athrxx, 6 weeks ago

The "Error running game: Game data not found" should be gone, now. But it might require you to re-detect the game (if the language field in the launcher is empty instead of having Spanish in it).

in reply to:  4 comment:6 by Blood138, 6 weeks ago

Westwood files are now detected and the game runs perfectly when first launched, but as soon as I restart ScummVM I get the same error message.

I hope you find these videos helpful.

1
https://youtu.be/zvIjzDXVRyo

2
https://youtu.be/OVCytus4hHY

3.
https://youtu.be/oaER0btfChc

comment:7 by Blood138, 6 weeks ago

It seems that with this build > 7d4dcf97 both versions (Floppy and Extracted) work perfectly fine.

EDIT: Nope, still get that same error message.

Last edited 6 weeks ago by Blood138 (previous) (diff)

comment:8 by athrxx, 6 weeks ago

Thanks for checking.

I have now even downloaded the 7d4dcf97 build myself, just to check if it contains the fix or not. It does. And it should work totally fine for Spanish, both for the installer package version and the extracted version.

But, like I said above, you do have to re-detect these Spanish games (remove them in the launcher, then add them again). Have you tried that?

comment:9 by Blood138, 6 weeks ago

I did it and it worked fine the first time but after that I got the same error message again.
I have to say that now the error seems very random. Sometimes I have no problem running the game but other times it refuses to work.

comment:10 by athrxx, 6 weeks ago

Okay, thanks. Now I am bit clueless. I have even tried to follow the steps in your videos, but I didn't get the error.

Since you said it has started to become very random: Is the detection entry always permanently broken, once it has shown the error (so that you have to re-detect)? Or does the same detection entry somehow work again when you try again?

If the entry doesn't work: Can you please click on "Game Options" and check if the "Language:" field is empty or if is still says "Spanish"?

comment:11 by Blood138, 6 weeks ago

I have made another video.

https://youtu.be/Pj61EyEYNII

As you can see, the floppy disk version doesn't work because the "Language" field is empty. When I add the game again it runs fine, but sometimes that field resets to blank for some reason.

comment:12 by athrxx, 6 weeks ago

I still can't reproduce it, but what I found strange in your video is that the launcher was in English, but the ctrl+F5 menu that was showing at 0:12 was in Spanish. It should be the same language as in the launcher.

What language settings do you actually have in the launcher?

comment:13 by Blood138, 6 weeks ago

The launcher language is set to Spanish except when I want to record a video to show you. And yes, the Ctrl+F5 menu never changes language, it is always in Spanish.

by Blood138, 5 weeks ago

Attachment: scummvm.Error.log added

comment:14 by Blood138, 5 weeks ago

I spent a few hours with this build > windows-x86-64-master-d6b4d0ef and everything seems to work fine. However, I think you should check the log file...

comment:15 by athrxx, 5 weeks ago

Thanks, that's a relieve. I really didn't have any ideas left ;-)

The other thing you mentioned at the beginning: "It crashes when attempting to remap controls "in-game" Is that still an issue? If yes, you might describe a bit more what you were doing. Or just make another video :-)

Thanks for the log. The warning shouldn't affect your gameplay, but I'll see that this gets fixed, too.

comment:16 by athrxx, 5 weeks ago

The stack access warnings should be gone for the lines in the log (803 and 844)...

in reply to:  15 comment:17 by Blood138, 5 weeks ago

Replying to athrxx:

The other thing you mentioned at the beginning: "It crashes when attempting to remap controls "in-game" Is that still an issue? If yes, you might describe a bit more what you were doing. Or just make another video :-)

This only happens with the latest official version, and it seems to affect more games as well.

https://youtu.be/p2F3zYLhPSQ

in reply to:  16 comment:18 by Blood138, 5 weeks ago

Last edited 5 weeks ago by Blood138 (previous) (diff)

comment:19 by athrxx, 5 weeks ago

Owner: set to athrxx
Resolution: fixed
Status: newclosed

Okay, thanks for the feedback. I'll close this ticket, then.

If you happen to encounter more of these stack access warnings (for different lines) you might want to open another ticket...

comment:20 by Blood138, 5 weeks ago

Thank you very much for your assistance and patience, athrxx.

Note: See TracTickets for help on using tickets.