Opened 7 weeks ago

Closed 7 weeks ago

#13488 closed defect (duplicate)

ILLUSIONS: Duckman - Crash after clicking anywhere in intro

Reported by: raziel- Owned by: raziel-
Priority: normal Component: Engine: Illusions
Version: Keywords: duckman, Big Endian(?)
Cc: Game:

Description

ScummVM 2.6.0git (May 16 2022 01:50:41)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC A/52 FreeType2 FriBiDi JPEG PNG GIF cloud (servers, local) TinyGL OpenGL (with shaders)

  • Start the game

While the intro runs with the soldier in his dugout talking

  • Press ESC to bring up the in-game menu
  • Return to the game and, with the now visible cursor, click anywhere

-> instant crash (log attached, i hope they will be helpful?)

Might be another Big Endian problem(?)

I believe the problem is the now visible cursor.
Normally clicking anywhere here would simply skip a line of dialogue, but with the cursor visible it *might* be that the game wants to do some action here, but none is possible?

Duckman (Windows/English)
duckman.gam: 172c0514f3793041718159cf9cf9935f, 29560832 bytes.

AmigaOS4 - PPC - SDL - BE
gcc (adtools build 11.3.0) 11.3.0

Attachments (1)

Crashlog_scummvm_2022-05-16_13-24-04.txt (40.9 KB ) - added by raziel- 7 weeks ago.

Download all attachments as: .zip

Change History (3)

comment:1 by dwatteau, 7 weeks ago

I don't think this is big-endian related, I had the same crash on x86-64 in issue #12717 (which has a gdb backtrace).

comment:2 by raziel-, 7 weeks ago

Owner: set to raziel-
Resolution: duplicate
Status: newclosed

Right, sorry for the duplicate.

Note: See TracTickets for help on using tickets.