Opened 2 years ago

Closed 2 years ago

#13486 closed defect (worksforme)

Games crashes in Tower-1 when trying to go down the stairs

Reported by: sndirsch Owned by: sndirsch
Priority: normal Component: Engine: Drascula
Version: Keywords:
Cc: Game: Drascula


ScummVM 2.5.1

Games crashes in Tower-1 when trying to go down the stairs

scummvm: ./common/util.h:74: T CLIP(T, T, T) [with T = short int]: Assertion `amin <= amax' failed.
/usr/bin/drascula: line 77: 6310 Aborted (core dumped) scummvm -g hq3x -f -n drascula

/usr/bin/drascula is a script which runs 'scummvm -g hq3x -f -n drascula'

Tried in Spanish and English. Same issue.
Current Freeware zip files from

OS: openSUSE Leap 15.3

scummvm.ini Entry

description=Drascula: The Vampire Strikes Back (DOS/Spanish)
guioptions=sndNoMIDI sndLinkSpeechToSfx lang_English

I'm attaching s savegame right before the issue.

Attachments (1)

drascula.027 (11.3 KB ) - added by sndirsch 2 years ago.

Download all attachments as: .zip

Change History (4)

by sndirsch, 2 years ago

Attachment: drascula.027 added

comment:1 by antoniou79, 2 years ago

I cannot reproduce the issue on Windows 10 x64 with 2.5.1 nor 2.6.0git, for the freeware 1.0 version with your setup (ogg audio and drascula-int-1.1) nor with the Steam version. Tried with the English version.

Also, I believe the correct command for 2.5.1 and 2.6.0git would be:

./scummvm -g opengl --scaler=hq --scale-factor=3 -f -n drascula


./scummvm -g surfacesdl--scaler=hq --scale-factor=3 -f -n drascula

Maybe it's a Linux specific issue, or something wrong with your data files (eg. some corrupted file)?

Also please double check that you actually are running ScummVM 2.5.1 as the command line parameters you've provided won't work on newer versions of ScummVM (ScummVM will still launch but it will ignore your gfx value and use defaults).
Just run a:

./scummvm -v
Version 0, edited 2 years ago by antoniou79 (next)

comment:2 by sndirsch, 2 years ago

Ok. I noticed that when I restart scummvm and load earlier save games the issue doesn't occur. But then later at some other place it crashes the same way (at least same error). I'm afraid that's a memory corruption somewhere, which occurs sooner or later. More or less impossible to reproduce and hard to debug.

Thanks for the hints about the command line options. I used the manual page for documentation. Seem it's outdated meanwhile. :-(

This ticket can be closed as WORKSFORME.

comment:3 by sndirsch, 2 years ago

Owner: set to sndirsch
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.