Opened 2 years ago

Closed 20 months ago

#13482 closed defect (fixed)

DIRECTOR: Improve "Maniac Sport" detection

Reported by: LukasThyWalls Owned by: tag2015
Priority: normal Component: Engine: Director
Version: Keywords: Manias Mansion Deluxe, AGS, Detection,
Cc: Game:

Description

Hello.

"Maniac Mansion Deluxe" is still weirdly detecte by ScummVM (Tested with 2.6.0git5613-g8f0da16853b)

In all version i tested (1.0 and 1.4), ScummVM asks between Maniac Mansion Deluxe and Maniac Sports (Windows/English) - Unknown Variant, and in the status window show the warning about unknown game variant of maniacsports-win:

For Maniac Mansion Deluxe 1.0:

Matched game IDs for the director engine: maniacsports-win

  {"MANIAC.EXE", 0, "3128b9f90e2f954ba704414ae854d10b", 9395050},

For Maniac Mansion Deluxe 1.4

Matched game IDs for the director engine: maniacsports-win

  {"MANIAC.EXE", 0, "465f972675db2da6040518221af5b0ba", 10409172},

However, looking the code, i see the Maniac Sports for director have other data:

https://github.com/scummvm/scummvm/blob/master/engines/ags/detection_tables.h#L5165

// Original Mac filename is Maniac Sports™
MACGAME1("maniacsports", "", "Maniac Sports", "2ce360c9ea2da80a2c6d1040b0ad92dd", 421218, 311),
WINGAME1("maniacsports", "", "MANIAC.EXE", "65d06b5fef155a2473434571aff5bc29", 371274, 311),

... very different to the Maniac Mansion Deluxe ones:

https://github.com/scummvm/scummvm/blob/master/engines/ags/detection_tables.h#L5165

GAME_ENTRY("maniacmansiondeluxe", "Maniac.exe", "3128b9f90e2f954ba704414ae854d10b", 9395050),  // v1.05
GAME_ENTRY("maniacmansiondeluxe", "Maniac.exe", "465f972675db2da6040518221af5b0ba", 10181366), // v1.3
GAME_ENTRY("maniacmansiondeluxe", "Maniac.exe", "465f972675db2da6040518221af5b0ba", 10409172),

So, i don't know why exactly the detection are confused between them, knowing there are others maniac.exe in the same AGS detection and in those case there isn't any confussion.

Thanks.


Also, there is a bunch of others games with similar issues there https://bugs.scummvm.org/ticket/13292

Change History (3)

comment:1 by aquadran, 2 years ago

Summary: Improve "Maniac Mansion Deluxe" detectionAGS: Improve "Maniac Mansion Deluxe" detection

comment:2 by criezy, 2 years ago

Component: Engine: AGSEngine: Director
Summary: AGS: Improve "Maniac Mansion Deluxe" detectionDIRECTOR: Improve "Maniac Sport" detection

Changing component to Director since the issue is with the Director engine falsely detecting Maniac Mansion Deluxe as Maniac Sport.

I also checked the issue still exist.
I think we will either have to graylist "maniac.exe", or improve the director detection to check that unknown variants are indeed director executables (as we do for unknown variants in the AGS engine).

comment:3 by tag2015, 20 months ago

Owner: set to tag2015
Resolution: fixed
Status: newclosed

Fixed in d74e12

Note: See TracTickets for help on using tickets.