Opened 5 months ago

Closed 4 months ago

#13481 closed defect (duplicate)

GUI: ScummVM quits after adding a game

Reported by: eisnerguy1 Owned by: criezy
Priority: normal Component: GUI
Version: Keywords:
Cc: Game:

Description (last modified by eisnerguy1)

I'm running this versions on macOS 10.14.6:
ScummVM 2.6.0git5785-g2a36aef83c9 (May 14 2022 04:29:14)

Any time I add a game, ScummVM quits immediately.

I ran ScummVM from the Terminal and "Segmentation fault: 11" is what happens when ScummVM quits:

/Applications/ScummVM/ScummVM.app/Contents/MacOS/scummvm
2022-05-14 17:00:31.946 scummvm[60862:8237239] NSDocumentController Info.plist warning: The values of CFBundleTypeRole entries must be 'Editor', 'Viewer', 'None', or 'Shell'.
objc[60862]: Class FIFinderSyncExtensionHost is implemented in both /System/Library/PrivateFrameworks/FinderKit.framework/Versions/A/FinderKit (0x7fffacdd93f0) and /System/Library/PrivateFrameworks/FileProvider.framework/OverrideBundles/FinderSyncCollaborationFileProviderOverride.bundle/Contents/MacOS/FinderSyncCollaborationFileProviderOverride (0x1101d3f50). One of the two will be used. Which one is undefined.
Segmentation fault: 11

Here's the macOS Problem Report:
attachment:"Problem Report.txt"

This "Segmentation fault: 11" problem does not happen in ScummVM 2.5.1.

Attachments (2)

scummvm-00001.png (62.4 KB ) - added by eisnerguy1 5 months ago.
Problem Report.txt (83.8 KB ) - added by eisnerguy1 5 months ago.

Download all attachments as: .zip

Change History (13)

by eisnerguy1, 5 months ago

Attachment: scummvm-00001.png added

comment:1 by eisnerguy1, 5 months ago

Description: modified (diff)

by eisnerguy1, 5 months ago

Attachment: Problem Report.txt added

comment:2 by eisnerguy1, 5 months ago

Description: modified (diff)

comment:3 by eisnerguy1, 5 months ago

Description: modified (diff)

comment:4 by eisnerguy1, 5 months ago

Description: modified (diff)

comment:5 by eisnerguy1, 5 months ago

Summary: ScummVM quits after adding a gameScummVM quits after adding a game on macOS

comment:6 by athrxx, 5 months ago

Thanks for the report.

Do you have some sorting enabled in the launcher (looks like 'Publisher' in the background)? If yes, does the problem also occur when you set the sorting to 'none'?

The problem with the crash after adding a game with sorting enabled is known. We'll fix it. At least I hope we do ;-)

in reply to:  6 comment:7 by eisnerguy1, 5 months ago

Replying to athrxx:

Thanks for the report.

Do you have some sorting enabled in the launcher (looks like 'Publisher' in the background)? If yes, does the problem also occur when you set the sorting to 'none'?

The problem with the crash after adding a game with sorting enabled is known. We'll fix it. At least I hope we do ;-)

Of course. I'm happy to help if I can. Yeah, I was sorting via "Publisher". The problem doesn't occur when switching to "None". I'm totally ok with using this workaround until the crash is hopefully fixed :)

comment:8 by antoniou79, 5 months ago

The issue reported seems to be a duplicate of https://bugs.scummvm.org/ticket/13413

comment:9 by digitall, 4 months ago

Component: --Unset--Port: Mac OS X
Summary: ScummVM quits after adding a game on macOSMACOS: ScummVM quits after adding a game

comment:10 by athrxx, 4 months ago

It's not really a MACOS thing. It's the same on Windows. And probably any system. It's a launcher bug, not something to do with the backend.

comment:11 by criezy, 4 months ago

Component: Port: Mac OS XGUI
Owner: set to criezy
Resolution: duplicate
Status: newclosed
Summary: MACOS: ScummVM quits after adding a gameGUI: ScummVM quits after adding a game

This is indeed a duplicate of bug #13413. So I am closing this one. Progress on the fix can be tracked in the other bug ticket.

Note: See TracTickets for help on using tickets.