Opened 5 months ago

Last modified 4 months ago

#13456 new defect

SDL: No Mouse or Keyboard with SDL 2.20

Reported by: eviltroooper Owned by:
Priority: normal Component: Common
Version: Keywords:
Cc: Game:

Description

I use emuelec for scummvm, on the last version they use Scummvm 2.6.0 and SDL 2.20.
With this version mouse and keyboard is not working anymore.
As you see if the dev use SDL 2.0.9 it works.

Is it possible to fix this?

from emuelec Dev:

This is definitely a SDL issue, as I compiled git version b21fd0c9aa075915658d65c1c61e9ee2fb23d363 with SDL 2.0.9 and it works fine (if I use the SDL2 2.0.9 library in /emuelec/lib) but I am not going to revert SDL, This needs to be fixed in Scummv (I think, as all the other programs that use keyboard with SDL work fine) because if I compile the same exact version with only the library change or if I use the SDL2.20 library instead then the mouse/keyboard stops working.

https://github.com/EmuELEC/EmuELEC/issues/879

Thanks.

Change History (8)

comment:1 by athrxx, 5 months ago

Is this a problem that occurs with any version of ScummVM on our downloads page?

https://www.scummvm.org/downloads/

Or is that an issue that only comes up in an unsupported (third-party product) setting?

comment:2 by eviltroooper, 5 months ago

Mhh i would like to say with any version, I tried 2.5.1, 2.4 and 2.6.1.

They developers tried newest scummvm with older SDL it works.
If we use SDL 2.20 it won’t work with every scummvm version

So it seems like Scummvm has a problem with SDL 2.20

Ohh Joystick is working..,

comment:3 by eviltroooper, 5 months ago

Emuelec dev say it’s not there bug..

:(

comment:4 by eviltroooper, 5 months ago

Ohh on other apps that use SDL keyboard and mouse working, only scummvm not..

comment:5 by eviltroooper, 5 months ago

And me again,
On your download page I can’t find version for aarch64

comment:6 by athrxx, 5 months ago

So, if you use any product that we actually offer and support, there isn't any bug?

comment:7 by eviltroooper, 5 months ago

I can’t say that, on windows anything is working.

For aarch64 you don’t offer a Package..

But it seems like it SDL 2.0.20

It it possible that SDL is the problem?

comment:8 by aquadran, 4 months ago

Summary: No Mouse or Keyboard with SDL 2.20SDL: No Mouse or Keyboard with SDL 2.20
Note: See TracTickets for help on using tickets.