#13437 closed defect (fixed)

AGS: Text in Maniac Mansion Deluxe not displaying properly

Reported by: eisnerguy1 Owned by: criezy
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description (last modified by eisnerguy1)

So, I've got Maniac Mansion Deluxe v1.4 running in ScummVM 2.6.0git5128-g84e761aef8c (Apr 16 2022 06:36:27) on macOS 10.14.6. The font is displaying kinda weirdly.

Here's a screenshot running the game in AGS 3.5.1.17:

And here's the game running in ScummVM 2.6.0git5128-g84e761aef8c (Apr 16 2022 06:36:27):

All of the text I've seen so far, while running Maniac Mansion Deluxe in ScummVM, has the same display problem.

Attachments (3)

Maniac_Mansion_Deluxe_AGS.png (34.6 KB ) - added by eisnerguy1 23 months ago.
Maniac_Mansion_Deluxe_ScummVM.png (38.9 KB ) - added by eisnerguy1 23 months ago.
scummvm-maniacmansiondeluxe-00000.png (25.4 KB ) - added by tag2015 21 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 by eisnerguy1, 23 months ago

Description: modified (diff)

by eisnerguy1, 23 months ago

by eisnerguy1, 23 months ago

comment:2 by eisnerguy1, 23 months ago

Description: modified (diff)

comment:3 by tag2015, 21 months ago

Tested using ScummVM 2.6.0git6337-g9f529d2db14 (Jun 5 2022 04:48:14), the problem seems to be solved.

comment:4 by antoniou79, 21 months ago

I can confirm that the issue seems solved; I get proper fonts and text display in the start screen and in-game.
Tested with 2.7.0git (build today from master HEAD).

comment:5 by tag2015, 15 months ago

The "chunky" fonts issue mentioned in this bugreport is solved. The fonts still are not 100% like the original, but that affects multiple games, not just MM deluxe.

Closing this, as we already have #12940 and #13568 related to these issues

comment:6 by tag2015, 15 months ago

Owner: set to criezy
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.