Opened 20 months ago

Closed 7 weeks ago

#13436 closed defect (fixed)

AGS: Maniac Mansion Deluxe - Excessive movement on iOS/Android

Reported by: warhorse6666 Owned by:
Priority: normal Component: Engine: AGS
Version: Keywords: Maniac Mansion Deluxe, iOS, Android
Cc: Game:

Description

When trying to play Maniac Mansion Deluxe (V1.4) on IOS (iOS 8+ package .ipa) Scummvm 2.5.1, All touch commands input to the verb menu system below the main screen result in character movement, this causes excessive movement commands when the characters should actually be standing still. The characters stand still and do not move in the Windows 64-bit Scummvm 2.5.1 when clicking commands but the current IOS (iOS 8+ package .ipa) Scummvm 2.5.1 results in this excessive movement.

Change History (10)

comment:1 by warhorse6666, 20 months ago

Component: Engine: AGSPort: iOS

comment:2 by warhorse6666, 20 months ago

Component: Port: iOSEngine: AGS
Keywords: AGS iOS added
Summary: Maniac Mansion Deluxe (AGS) Excessive movement on IOSManiac Mansion Deluxe (AGS) Excessive movement on iOS

comment:3 by aquadran, 18 months ago

Summary: Maniac Mansion Deluxe (AGS) Excessive movement on iOSAGS: Maniac Mansion Deluxe (AGS) Excessive movement on iOS

comment:4 by tag2015, 8 months ago

This is not an iOS bug, I can reproduce it using latest 2.8git on Android.
Occurs only when using "Direct Mouse" mode.
In short, when clicking the verbs bar, before changing the verb the game does a "walk to" the clicked area.

comment:5 by tag2015, 8 months ago

Summary: AGS: Maniac Mansion Deluxe (AGS) Excessive movement on iOSAGS: Maniac Mansion Deluxe - Excessive movement on iOS/Android

comment:6 by larsamannen, 4 months ago

I've tested this on latest master (4d1b38f) on iOS and to me it looks like this is fixed. There are no movements when clicking on the verbs.

comment:7 by tag2015, 4 months ago

I tested on Android with the latest 2.7.1 and master, and I can't reproduce anymore. I think this can be closed

comment:8 by lwcorp, 4 months ago

Game: Maniac Mansion
Keywords: Maniac Mansion AGS removed

comment:9 by tag2015, 3 months ago

Game: Maniac Mansion
Keywords: Maniac Mansion Android added

@larsmannen can this be closed?

comment:10 by tag2015, 7 weeks ago

Resolution: fixed
Status: newclosed

I'll go ahead and close this one. I tested again on ipad and android and I can't reproduce the issue at all (on MM deluxe or other games)

Note: See TracTickets for help on using tickets.