Opened 8 months ago

Closed 7 months ago

#13433 closed defect (fixed)

SCUMM: Amiga Monkey2 color problem when using the stick with the dog at the mansion

Reported by: dwatteau Owned by: bluegr
Priority: normal Component: Engine: SCUMM
Version: Keywords: amiga, palette, colors
Cc: Game: Monkey Island 2

Description

As discovered by RetroSpeedruns on YouTube here:
https://www.youtube.com/watch?v=lennSAcOqag

In the Amiga version of Monkey Island 2, if you pick up the stick under the mattress inside the jail, and then use it on the dog at the front of the Governor Mansion's on Booty Island, Guybrush's reaction will have some very strange colors, as if the sprite was drawn with an invalid palette for that scene.

This is probably an original game bug, since the video above was made with WinUAE. I can reproduce it with ScummVM, but only with my Amiga version (from the Limited Run Games set), so it probably has something to do with Amiga palette handling.

I think that this animation can be triggered in two places:

  • when giving the stick to the Mansion dog (script 209, room 53).
  • when using the stick with the dead prisoner in the jail (script 201, room 29): there, the colors are fine.

Attachments (1)

monkey2-amiga.s03 (26.9 KB ) - added by dwatteau 8 months ago.
Amiga English version: use the stick with the dog

Download all attachments as: .zip

Change History (4)

by dwatteau, 8 months ago

Attachment: monkey2-amiga.s03 added

Amiga English version: use the stick with the dog

comment:1 by dwatteau, 7 months ago

Costume 55 is the one with an invalid palette for the Governor's Mansion.

Here's my PR proposal for this:
https://github.com/scummvm/scummvm/pull/3841

comment:2 by bluegr, 7 months ago

Nice work! The PR has been merged, so this can be closed now

comment:3 by bluegr, 7 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.