Opened 16 years ago

Closed 16 years ago

#1342 closed defect (fixed)

ZAK: Actors not updating (Regression)

Reported by: Kirben Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

Latest ScummVM cvs version.
English version of Zak McKracken
Compiled under mingw with GCC 3.2.3 and running under
Windows XP.

When Zak parachutes out or plane or teleports out of
space ship into water, his actor stops updating as he is
failing. Once he lands in water and stops talking, his
actor only updates as dolphin passes in distance.
If I call over the dolphin with kazoo, I don't see the
dolphin come out of the sea and it is invisable until Zak
moves over it.
These problems are caused by scumm/actors.cpp
revision 1.161.

Zak's body isn't shown as we see him drop into the sea
either, but that isn't a regression and occurs in 0.5.1 too.

Board plane, parachute out of plane, notice Zak isn't
shown all the time he is falling.
After Zak stops talking notice that his actor only
updates as dolphin passes in distance.
Use kazoo to call dolphin, notice the dolphin doesn't
appear until Zak moves over it.

fingolfin, could you have a look at this issue ?

Ticket imported from: #860823. Ticket imported from: bugs/1342.

Attachments (2)

zak.s09 (52.6 KB ) - added by Kirben 16 years ago.
V2 Zak save
zak64.s08 (4.5 KB ) - added by Kirben 16 years ago.
V1 Zak save

Download all attachments as: .zip

Change History (5)

by Kirben, 16 years ago

Attachment: zak.s09 added

V2 Zak save

by Kirben, 16 years ago

Attachment: zak64.s08 added

V1 Zak save

comment:1 by fingolfin, 16 years ago

To clarify this, I don't think the problem is "caused by scumm/
actors.cpp revision 1.161", rather I would think it is "exposed by
..." :-)

comment:2 by fingolfin, 16 years ago

Resolution: fixed
Status: newclosed

comment:3 by fingolfin, 16 years ago

Fixed in CVS (need to set Actor::needRedraw to true when
changing the elevation).

Note: See TracTickets for help on using tickets.