Opened 3 months ago

Closed 2 weeks ago

#13381 closed defect (fixed)

ULTIMA: Elevator in level 1 does not work in Crusader: No Remorse

Reported by: MaddoScientisto Owned by: mduggan
Priority: high Component: Engine: Ultima
Version: Keywords: Crusader
Cc: Game: Crusader: No Remorse

Description

The elevator near the end of level 1 does not do anything at all when entered.
I'm playing on

tried on nightly scummvm-2.6.0git-4701-g9e144deb150-general but also happens on release

I attached a save in the secret room, just exit the room, go up the elevator and go to the end of the hallway, enter the elevator

I'm playing with a desktop resolution of 2560x1440 and 125% screen scale, high resolution is enabled in the game settings and scummvm is running on a window (not maximised) that covers most of the screen.

Attachments (2)

remorse.001 (99.6 KB ) - added by MaddoScientisto 3 months ago.
scummvm-2.6.0git-4701-g9e144deb150-general_2022-03-31_15-20-28.png (317.0 KB ) - added by MaddoScientisto 3 months ago.

Download all attachments as: .zip

Change History (10)

by MaddoScientisto, 3 months ago

Attachment: remorse.001 added

comment:1 by lotharsm, 5 weeks ago

Summary: Elevator in level 1 does not workULTIMA: Elevator in level 1 does not work in Crusader: No Remorse

comment:2 by lotharsm, 5 weeks ago

Priority: blockerhigh

comment:3 by mduggan, 4 weeks ago

I'm not sure how the game got into this state. I replayed around this bit and the elevator worked in both normal and "high resolution" modes. It doesn't seem to be a release blocker as it works for me when I test so it's not a 100% game breaking bug - but quite annoying none the less.

I initially thought the description meant this was played in a custom resolution using the ini file, but if it's just "high resolution" mode (1024x768) I'll need to investigate more how the elevator got stuck open.

Last edited 4 weeks ago by mduggan (previous) (diff)

comment:4 by MaddoScientisto, 3 weeks ago

I can confirm I didn't do any ini editing, I just pressed the maximise button on the window, I'll try and see if it happens again if I load the game on a smaller window

Last edited 3 weeks ago by MaddoScientisto (previous) (diff)

comment:5 by mduggan, 3 weeks ago

Thanks. I tried loading with and without high res mode and for that save it still reproduces. I played through to that point myself in both modes and it didn't happen for me though. So, something is broken in that save and I need to work out what it is and (probably harder?) how it got that way.

comment:6 by MaddoScientisto, 3 weeks ago

https://i.imgur.com/Hm8AyMp.png
I just tried to disable high resolution and set a smaller window and load the save and it still happens 100% of the time to me.
The only enabled things in the options are frame limiting and cheats, the rest is all default

comment:7 by mduggan, 2 weeks ago

I've worked out why the elevator doesn't trigger - it seems that a "teleporting" flag which is normally set by the elevator is already set in this savegame, even though it should get cleared at the end of teleports and elevator moves.

It's not clear how the game got into this state, but it would be nice if I could create a workaround. I'll need to carefully check what's possible as it could break other things to just reset this flag on load.

comment:8 by mduggan, 2 weeks ago

Owner: set to mduggan
Resolution: fixed
Status: newclosed

Rechecking the disassembly, there was a workaround for this problem (I presume?) in the original games that cleared this flag when you start selection or grab items ('s' or 'g'). That should work pretty well, so I copied it and pushed it in 75b8da08aa6.

Ported the same to the 2.6.0 release branch in cd67afcdba5.

Note: See TracTickets for help on using tickets.