Opened 3 months ago

Closed 3 days ago

#13377 closed defect (fixed)

AGS: lamplightcity (Lamplight City) crash while Adelaide is speaking to Charlotte Robineaux

Reported by: mpalermo1983 Owned by: criezy
Priority: high Component: Engine: AGS
Version: Keywords: lamplight city crash
Cc: Game:

Description (last modified by mpalermo1983)

Game crashes while Adelaide is speaking to Charlotte Robineaux while trimming her hair.

Bug seems to be critical as it blocks progression.

Version: ScummVM 2.6.0git4642-g3610df85c63 (Mar 27 2022 04:50:26)
Game Language: English
OS: Windows 10 Pro 21H2 19044.1586
Game Version: GOG 1.10 (latest)

Debug window shows:
[2022-03-27 23:47:10] ERROR: !Character cCharlotte speech view 180 does not have necessary loop 0 or it has no frames; and there's no valid loop to fall back.!

Attached savegame, for reproducing, do the following:
-Load savegame
-Speak to the woman sitting in the chair (Adelaide)
-Choose topic "Charlotte Robineaux"
-Select "Here is what I want to know..."

As soon as the conversation is finished, there is a scene where Adelaide speaks her first line to Charlotte and game crashes when there seems to be a reply from Charlotte.

Attachments (1)

lamplightcity.2.rar (1.1 MB ) - added by mpalermo1983 3 months ago.
savegame right before speaking to Adelaide, need to choose "Charlotte Robineaux" and then "Here is what I want to know...", after that comes the scene where Adelaide speaks and game crashes

Download all attachments as: .zip

Change History (7)

by mpalermo1983, 3 months ago

Attachment: lamplightcity.2.rar added

savegame right before speaking to Adelaide, need to choose "Charlotte Robineaux" and then "Here is what I want to know...", after that comes the scene where Adelaide speaks and game crashes

comment:1 by mpalermo1983, 3 months ago

Description: modified (diff)
Priority: highblocker

comment:2 by mpalermo1983, 3 months ago

Description: modified (diff)

comment:3 by mpalermo1983, 3 months ago

Summary: Lamplight City (AGS) - 3rd Case - Crashes while Adelaide is speaking to Charlotte RobineauxAGS: Lamplight City - Crash while Adelaide is speaking to Charlotte Robineaux

comment:4 by mpalermo1983, 3 months ago

Summary: AGS: Lamplight City - Crash while Adelaide is speaking to Charlotte RobineauxAGS: lamplightcity (Lamplight City) crash while Adelaide is speaking to Charlotte Robineaux

comment:5 by lotharsm, 5 weeks ago

Priority: blockerhigh

comment:6 by criezy, 3 days ago

Owner: set to criezy
Resolution: fixed
Status: newclosed

I reproduced the crash about a week ago, but trying again today it works properly. So it looks like of the commits I merged from upstream fixed the issue.

Note: See TracTickets for help on using tickets.