Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#13370 closed defect (fixed)

SCUMM: Loom (EGA) - Rusty teleports from blocking the Pattern hole to his corpse

Reported by: antoniou79 Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Version: Keywords: teleport, glitch
Cc: Game: Loom

Description

This in on Windows 10 x64, with a recent local build from HEAD master of 2.6.0git, testing with LOOM DOS EGA, using the orchestral audio feature.

For this I've applied the patch for the MT-32 upgrade to LOOM and set my Audio settings for the game to use "MT-32 emulator" as Music device. You may also need to do that for the attached save game to work.

How to reproduce:
Enter the hole for the Blacksmith's guild, with the Rusty corpse. Then try to exit through that hole to Outside the Pattern.

What happens:
Rusty appears and floats to his corpse, starts talking to Bobbin "Well, well, ..." then continues to float quickly and reaches the Pattern hole, and finally abruptly teleports back over his corpse.
Also, if the user presses Esc to skip this cutscene, Rusty assumes his "blocking" position over his corpse and says the quote he's supposed to say when blocking Bobbin from leaving through the hole the first time.

What should happen:
Rusty should float / "walk" up to his corpse and then talk to Bobbin, stopping him from exiting (and the user loses control at that point anyway) -- Rusty does not have to go and block Bobbin from leaving through the hole in this case.

I'm including a save game.

Attachments (1)

loom-ega.s69 (11.2 KB ) - added by antoniou79 8 months ago.

Download all attachments as: .zip

Change History (3)

by antoniou79, 8 months ago

Attachment: loom-ega.s69 added

comment:1 by eriktorbjorn, 8 months ago

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed

I believe this bug has been fixed now. Could you please test to see if you can find any problems with it?

comment:2 by antoniou79, 8 months ago

I can confirm the issue is fixed with your fix in Loom EGA DOS.

Note: See TracTickets for help on using tickets.