Opened 3 months ago

Closed 6 weeks ago

#13369 closed defect (fixed)

SCUMM: Loom (EGA) black thumbnail of focused object after reload

Reported by: antoniou79 Owned by: athrxx
Priority: normal Component: Engine: SCUMM
Version: Keywords: save, load, thumbnail
Cc: Game: Loom

Description

This in on Windows 10 x64, with a recent local build from HEAD master of 2.6.0git, testing with LOOM DOS EGA, using the orchestral audio feature.

For this I've applied the patch for the MT-32 upgrade to LOOM and set my Audio settings for the game to use "MT-32 emulator" as Music device. You may also need to do that for the attached save game to work.

How to reproduce:
In some screen of the game, click on an object and wait for Bobbin to focus on it (the thumbnail and the description text will appear). At that point save the game. Then reload the same game.

What happens:
If the user clicks on *that same focused object*, the thumbnail image of the target object is a black filled thumbnail with just the description text on it. The user has to click somewhere else and then (hover or click) on the object again for the thumbnail to be shown properly.

What should happen:
The thumbnail of the focused object should either appear focused with the text description (as it was at the point of saving) or when clicked it should show the thumbnail with the description properly and not as a black box.

I'm including a save game that one can load to see this happening, but this seems to be a general issue not particular to a room or an item. I am also attaching a screenshot of the issue.

Attachments (2)

scummvm-loom-ega-00020.png (34.4 KB ) - added by antoniou79 3 months ago.
loom-ega.s82 (14.6 KB ) - added by antoniou79 3 months ago.

Download all attachments as: .zip

Change History (5)

by antoniou79, 3 months ago

Attachment: scummvm-loom-ega-00020.png added

by antoniou79, 3 months ago

Attachment: loom-ega.s82 added

comment:1 by athrxx, 3 months ago

Thanks, but this is known.

https://bugs.scummvm.org/ticket/6011

It is not easy to fix. My disasm research shows that our loading process is complete and correct, but our saving process is lacking. We do generate our savestates without running the save script (which would display the original save dialog and handle the input).

It it is a bit delicate to work around this. Either we'd have to imitate the save script behavior when saving while somehow suppressing the display and handling of the dialog. Or we'd have to run some restoration script functions on top of the loading. But if I fully understood how to do it this would long be fixed...Sooner or later someone will do it... :-)

comment:2 by athrxx, 3 months ago

There is now a pull request with an attempt to fix this.

https://github.com/scummvm/scummvm/pull/3792

Please test if you have time...

comment:3 by athrxx, 6 weeks ago

Owner: set to athrxx
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.