Opened 11 months ago

Closed 3 months ago

#13368 closed defect (duplicate)

MYST3: Unknown Game Variant for Myst 3 Exile CD Version

Reported by: anneszy Owned by: tag2015
Priority: normal Component: Engine: Myst3
Version: Keywords: detection
Cc: anneszy Game: Myst 3: Exile

Description

Installed latest version of Scummvm 2.5.1. Windows 10.
The game in 'F:\' seems to be an unknown game variant.

Please report the following data to the ScummVM team at https://bugs.scummvm.org/ along with the name of the game you tried to add and its version, language, etc.:

Matched game IDs for the myst3 engine: myst3-win

{"RSRC.m3r", 0, "a2c8ed69800f60bf5667e5c76a88e481", 1223862},
{"ENGLISH.m3t", 0, "19dcba1074f235ec2119313242d891de", 5658925},

Change History (9)

comment:1 by digitall, 9 months ago

Component: --Unset--Engine: Myst3
Keywords: detection added
Summary: Unknown variant - Myst3 cdMYST3: Unknown Game Variant for Myst 3 Exile CD Version

comment:2 by digitall, 9 months ago

anneszy: Can you provide any other information about this version to allow developers to locate a copy for testing? i.e. CD pressing ID, publisher, language, date of release etc.

comment:3 by jballe01, 6 months ago

I am receiving the same error for the same game (Myst III: Exile). The publisher is Ubisoft or Cyan Worlds. I am running ScummVM on a Windows 10 machine.

Myst III: Exile (tm)
Version 1.27 for Windows 95 / 98 / ME / XP and Mac OS 8.1 or 9.1 or OS 10.1
July 21, 2003

  1. Hardware Requirements

Windows:

233 MHz Pentium II or 300 MHz K6-2 or faster
Windows 95/98/ME/XP
64 MB RAM
250 MB Available Hard Drive Space
4x DVD-ROM drive or faster
640x480 Display
Optional 3D Acceleration
Required 8MB Video Card Supporting 32-bit Color
DirectX 9 compatible Sound & Video Cards
QuickTime 6 or higher required

  1. List of Compatible Hardware

Below is a list of video cards that are supported by Myst III: Exile's Hardware Mode.
Hardware Mode may not work correctly on your computer if your card is not on this list.
Try running Myst III: Exile in Software Mode.


nVidia Riva TNT
nVidia Riva TNT2
nVidia GeForce DDR, SDR
nVidia GeForce 256
nVidia GeForce2
nVidia GeForce2 GTS, Pro, MX
Guillemot Vanta
ATI Rage 128

ATI Rage Pro 128 VR
ATI Rage Pro 128
ATI Rage Pro M3
ATI Rage Mobility M12X
ATI Radeon
Matrox G200
Matrox G450
Savage 2000
Savage 3D
Voodoo 4 4500
Voodoo 5 5500
Kyro II

This is the third game in the Myst game series. I hope this helps.

comment:4 by macca8, 5 months ago

@digitall
This appears to be a duplicate of the CD version identified in #12865, which has already been added, but missed the 2.5.1 release.
Aquadran has confirmed that the commit associated with this change will also be available in the 2.6.0 release.

comment:5 by macca8, 5 months ago

@jballe01
Are you suggesting that your version of Myst III is also a CD version, and is displaying the same error with exactly the same file checksums as listed above?

To my knowledge, version 1.27 was exclusive to DVD versions.

comment:6 by jballe01, 5 months ago

I've installed 2.6.0 on Windows 10 and attempted to the same Myst III game from a 10th Anniversary DVD edition (my apologies) and received the following error:

The game in 'D:\' seems to be an unknown game variant.

Please report the following data to the ScummVM team at https://bugs.scummvm.org/ along with the name of the game you tried to add and its version, language, etc.:

Matched game IDs for the myst3 engine: myst3-win

{"ENGLISH.m3t", 0, "74726de866c0594d3f2a05ff754c973d", 3407120},
{"RSRC.m3r", 0, "a2c8ed69800f60bf5667e5c76a88e481", 1223862},

Please let me know if you need any further information.

Note - I was able to launch Myst I and II from the same DVD set without any errors.
Regards,
Jim

comment:7 by macca8, 5 months ago

@jballe01
Thanks for confirming that you do indeed have the DVD version.
In some good news, your version is actually listed as the default DVD entry, so it will need one of the ScummVM devs to sort out why it's not being properly detected.

Fortunately, your exact version is already reported in #13799, so you may like to follow its progress there.

Last edited 5 months ago by macca8 (previous) (diff)

comment:8 by tag2015, 5 months ago

@jballe01
Did you follow the steps in bugreport #13799? This is most likely the same issue,
you can't run the game directly from the DVD, you need to copy the files and move the language file.

comment:9 by tag2015, 3 months ago

Owner: set to tag2015
Resolution: duplicate
Status: newclosed

This OP's version was already reported in #12865.
The other user didn't follow up and his issue is reported in bug #13799 anyway (which is solved, too)

Closing

Note: See TracTickets for help on using tickets.