Opened 7 months ago

Closed 3 weeks ago

#13362 closed defect (worksforme)

SCI: Shivers palette is wrong during the elevator puzzles

Reported by: neuromancer Owned by: bluegr
Priority: normal Component: Engine: SCI
Version: Keywords:
Cc: Game: Shivers 1

Description

When the player should solve the puzzles to use the elevators, the background colors seems change at some point (after trying to solve the solve the current puzzle for several minutes). Please check the images to see how it changes because they look corrupted.

Attachments (2)

2.jpg (113.9 KB ) - added by neuromancer 7 months ago.
1.jpg (130.3 KB ) - added by neuromancer 7 months ago.

Download all attachments as: .zip

Change History (6)

by neuromancer, 7 months ago

Attachment: 2.jpg added

by neuromancer, 7 months ago

Attachment: 1.jpg added

comment:1 by sluicebox, 7 months ago

Component: --Unset--Engine: SCI
Summary: Colors palette is wrong during the elevator puzzlesSCI: Shivers palette is wrong during the elevator puzzles

Can you attach a save right before this part so that I can reproduce? Since I don't know Shivers, I'll need instructions for exactly what to do to trigger this. (Even if that's just 'wait around for a few minutes'.)

Thanks!

Last edited 7 months ago by sluicebox (previous) (diff)

comment:2 by bluegr, 5 months ago

Trying to decipher what's in this bug report.
There are puzzles that need to be solved to use the elevators that are found throughout the museum. All elevators start with a 4x4 grid, which increases in difficulty each time they are called, reaching a 6x6 grid.

The elevator puzzle in this bug is in room 6300, and the associated elevator leads to room 4630.

There are three elevators in total in the game. More information can be found below:
https://shivers.fandom.com/wiki/Elevator

comment:3 by sluicebox, 4 months ago

Well this actually got me playing Shivers for the first time! =0

From the screenshot this could either be room 6300 (rm6v300) or room 38130 (rm38v130); they both use picture 6300. There's not much to the scripts in the individual elevator rooms. The common code for the puzzle is in script 960.

I haven't gotten any elevator rooms to change color. And I don't see anything in the relevant scripts that set a timer or do any kind of waiting or drawing beyond the basic puzzle views.

Maybe there's some global timer event later in the game that intentionally/unintentionally does this?

I'm not sure what else to do without a save file or further info.

comment:4 by bluegr, 3 weeks ago

Owner: set to bluegr
Resolution: worksforme
Status: newclosed

I've been unable to reproduce this, and since we don't have a saved game and a scenario where this is palette change appears, there's not much that can be done here.

Closing as worksforme. If you can reproduce this and provide a saved game, we'd be glad to check the issue out!

Note: See TracTickets for help on using tickets.