Opened 5 months ago

Closed 9 days ago

#13346 closed defect (fixed)

SANITARIUM: Control problem and crashes PS3

Reported by: JBLeopard Owned by: alxpnv
Priority: high Component: Port: PS3
Version: Keywords:
Cc: JBLeopard Game: Sanitarium

Description

Hello, I have been testing this game with the last daily build for a long time and continuously, the game has control problems, with the button mapping on the PS3 pad you can only move the cursor, to solve that I try the game using a mouse by USB port on the console and the action keys work perfectly but a problem occurs when trying to have a dialogue with the characters to choose an option, the game freezes and you have to do a forced shutdown of the console, it is unplayable, I would like enjoy this game on PS3 like I did with Blade Runner or Nightlong: Union City Conspiracy finishing them 100%. Thank you very much for your great effort and dedication in the development of Scummvm, you make it possible for us to enjoy those great vintage games, greetings from Spain.

Attachments (2)

crash_sanitarium_demo_powerpc.png (128.5 KB ) - added by dwatteau 2 months ago.
Reproducing the crash in the demo; talk to the person on the right. Notice that no text appears at the bottom here
asylum_crash_ppc.txt.gz (3.6 KB ) - added by dwatteau 2 months ago.
(gzip'd) GDB backtrace on PowerPC. The LOBYTE() and BYTE1() asylum macros look unsafe for big-endian

Download all attachments as: .zip

Change History (21)

comment:1 by aquadran, 2 months ago

Summary: Control problema and crashes PS3PS3: Control problem and crashes PS3

comment:2 by dwatteau, 2 months ago

Hi,

Thank you for reporting this.

I can reproduce the crash on a PowerBook G4, which has a similar processor. I'm attaching a screenshot and a debugger log.

I think the crash may come from the following LOBYTE() and BYTE1() macros, which look unsafe for big-endian:
https://github.com/scummvm/scummvm/blob/6a3e97d86391202ea01fbdec59219ed006976899/engines/asylum/shared.h#L922

by dwatteau, 2 months ago

Reproducing the crash in the demo; talk to the person on the right. Notice that no text appears at the bottom here

comment:3 by dwatteau, 2 months ago

Summary: PS3: Control problem and crashes PS3SANITARIUM: Control problem and crashes PS3

by dwatteau, 2 months ago

Attachment: asylum_crash_ppc.txt.gz added

(gzip'd) GDB backtrace on PowerPC. The LOBYTE() and BYTE1() asylum macros look unsafe for big-endian

comment:4 by lotharsm, 7 weeks ago

Priority: normalhigh

comment:5 by alxpnv, 7 weeks ago

@dwatteau: Is this crash reproducible with the latest master?

comment:6 by dwatteau, 7 weeks ago

@alxpnv: Yes, thank you for your commit, it does fix the crash and the missing text issue on my machine.

Can it be merged into the 2-6 branch as well?

(Also, this bug report can't be closed yet, since it reported a crash and a PS3 usability problem; the latter is still true but not as important for the 2.6.0 release in my opinion.).

@JBLeopard: The crash problem should be fixed in a new PS3 daily build available within the next 24 hours. Thanks for reporting this.

comment:7 by JBLeopard, 7 weeks ago

Hello, on PS3 I will try tomorrow then, thanks, about the pad problem, for this game do you have to use a mouse on PS3 necessarily?

comment:8 by lotharsm, 7 weeks ago

The commit in question should indeed be backported into branch-2-6.

After JBLeopard confirmed that the crash is fixed, we should probably lower priority of this bug again since the main blocking issue is fixed.

comment:9 by JBLeopard, 7 weeks ago

Hello, I just tried it with the latest version and it works perfectly, it no longer freezes in the dialogs, I have tested it with a USB mouse, it is playable, thanks to all of you who have made it possible.

comment:10 by lotharsm, 7 weeks ago

Thank you for reporting back! So - since the commit in question has been backported to the 2.6.x branch, we can close this, right?

in reply to:  10 comment:11 by alxpnv, 6 weeks ago

Replying to lotharsm:

Thank you for reporting back! So - since the commit in question has been backported to the 2.6.x branch, we can close this, right?

Not yet. JBLeopard has also reported a problem with the controls. So can you please just lower the priority back to normal?

in reply to:  7 comment:12 by alxpnv, 6 weeks ago

Replying to JBLeopard:

Hello, on PS3 I will try tomorrow then, thanks, about the pad problem, for this game do you have to use a mouse on PS3 necessarily?

I hope this problem is resolved in the latest development build:

× for left click
◯ for right click
□ to show inventory

comment:13 by lotharsm, 6 weeks ago

Can someone confirm if this bugs is fixed? Doing some clean-up in the bug tracker since we are approaching the next release.

comment:14 by JBLeopard, 6 weeks ago

Hello, good morning, last night I got to chapter 3 on PS3, the game must be played with a USB mouse because the right and left buttons are not mapped on the console pad, that is, you need to connect a mouse to the console, for the rest I have not suffered any freezing in the dialogues with the characters, I have only had three reboots of the application playing but I think it is due to the amount of RAM that the console has, I have not given it much importance because I am recording the game every 15 minutes and so I can advance in the story, thanks and greetings.

comment:15 by dwatteau, 6 weeks ago

Hi,

Thanks for your test!

Here with yesterday's ScummVM 2.6.0pre285-g3f7b5ab0e45 and the demo version on PS3, the crash is indeed gone, but there are still some controller issues:

  • The × and ◯ buttons now work
  • but I couldn't find any button to pass the cutscenes (as does the Esc key on PC)
  • More importantly: once you start talking to someone, the game continues playing but the controller doesn't react anymore: neither the analog sticks nor the buttons do anything anymore, and the Start button doesn't open the ScummVM menu anymore either. I can only use the PS button to return to the main PS3 menu.

So with the controller problems, a USB mouse is still required at the moment.

in reply to:  15 ; comment:16 by alxpnv, 10 days ago

Replying to dwatteau:

  • but I couldn't find any button to pass the cutscenes (as does the Esc key on PC)
  • More importantly: once you start talking to someone, the game continues playing but the controller doesn't react anymore: neither the analog sticks nor the buttons do anything anymore, and the Start button doesn't open the ScummVM menu anymore either. I can only use the PS button to return to the main PS3 menu.

I've added a mapping for the Esc key (△) and adjusted the keymapper for dialogs. Can you please check if the demo is now playable with the latest development build?

in reply to:  16 ; comment:17 by dwatteau, 9 days ago

Replying to alxpnv:

I've added a mapping for the Esc key (△) and adjusted the keymapper for dialogs. Can you please check if the demo is now playable with the latest development build?

Yes, I can confirm that both the Esc key mapping and dialogs are now OK with today's development build for PS3. The demo now appears to be fine with a controller. Thank you for this!

in reply to:  17 comment:18 by alxpnv, 9 days ago

Replying to dwatteau:

Yes, I can confirm that both the Esc key mapping and dialogs are now OK with today's development build for PS3. The demo now appears to be fine with a controller. Thank you for this!

Thank you very much for your help! Closing this

comment:19 by alxpnv, 9 days ago

Owner: set to alxpnv
Resolution: fixed
Status: newclosed

Thanks for the report

Note: See TracTickets for help on using tickets.