Opened 2 years ago

Closed 20 months ago

Last modified 20 months ago

#13344 closed defect (fixed)

AGS: Several animation issues in Chzo mythos special edition games

Reported by: d0k3 Owned by: criezy
Priority: high Component: Engine: AGS
Version: Keywords: trilbysnotes, chzo, ags
Cc: Game:

Description

One place where this happens is in the end scene of Trilby's Notes. Agent Trilby is laying on a tree stump, injured and dying. However, as soon as he starts talking, his 'injured' animation gets replaced by his normal 'standing up' animation and stays that way. I'll attach a savegame of this happening in progress.

This isn't the only place where this happens. In Trilby's Notes it also happens when the druid is captures by Chzo. It happens as well in 7 Days a Skeptic, when the new ships captain is killed, and I've seen it happening in 6 Days a Sacrifice a lot, especially when author commentary is turned on.

SCUMMVM version: 2.5.1 release on Windows 10
Game version: several games affected, here specifically Trilby's Note Special Edition (http://www.g4g.it/2009/11/30/fullyramblomatic-special-editions-pack/, link from authors page)
How to reproduce: Simply play the game to the end, it will happen at that point regardless of what you do

Attachments (2)

trilbysnotes.001 (192.7 KB ) - added by d0k3 2 years ago.
Savegame of the bug happening in progress
saves.zip (24.0 KB ) - added by i30817 20 months ago.

Download all attachments as: .zip

Change History (9)

by d0k3, 2 years ago

Attachment: trilbysnotes.001 added

Savegame of the bug happening in progress

comment:1 by i30817, 2 years ago

There recently has been a fix for a regression with views from 3.5.0 to 3.6.0 https://github.com/adventuregamestudio/ags/issues/1698

Might be related.

comment:2 by criezy, 2 years ago

The description of this bug here sounds like it could indeed be the same bug. So it would be worth checking again in ScummVM now that the fix has been merged (I did this yesterday).

comment:3 by i30817, 21 months ago

Doesn't seem to help, at least with the savegame here (which might be the wrong approach to reproducing since it's already in that state though).

by i30817, 20 months ago

Attachment: saves.zip added

comment:4 by i30817, 20 months ago

Ok, i think this is not happening anymore. Or at least it's random. I played through the game to the ending twice, in recent master scummvm and upstream ags and the final scene doesn't start standing (although if i load the savegame posted here, it does).

Here are two savegames, one in the AGS name/format, another in the scummvm name/format from the recent masters to test it out, just 'touch stump' when loading them then keep pressing a key to skip the 'flashback' cutscene until you're at the stump again; you start downed.

I didn't do a regression test to check when this was 'fixed' in scummvm (if it was, and it isn't a random bug).

comment:5 by i30817, 20 months ago

If you're wondering what 'recent master scummvm' means it's a7f29a1c6e2f04df9d4d4a360062a14562078e0b

comment:6 by criezy, 20 months ago

Owner: set to criezy
Resolution: fixed
Status: newclosed

Thank you for testing. Since I already suspected that it had been fixed, I will close this bug. It can be reopen if we find out it was not fixed after all.

comment:7 by i30817, 20 months ago

I did see a avatar change in the rooftop scene in scummvm (not ags) just before the ending location but couldn't get a save for it.

It was weird, for a while the main character changed to one of the serial killers of the series. I suspect it might be a random on purpose scene alteration, since this is supposed to be a horror game, so i didn't report it.

Note: See TracTickets for help on using tickets.