Opened 7 months ago

Closed 5 months ago

#13322 closed defect (fixed)

SCUMM: FT (demo): Two background music tracks playing at the same time in the intro video

Reported by: AndywinXp Owned by: AndywinXp
Priority: normal Component: Engine: SCUMM
Version: Keywords: smush, scumm, insane
Cc: AndywinXp Game: Full Throttle

Description

To reproduce this, simply open the demo of Full Throttle found in the ScummVM website, and play the introductory video until the end.

At a technical level, what happens is that two SAUD channels with flag 64 (IS_BACKGROUND_MUSIC) are being played on top of each other.

I can't find in the disasm if having two tracks with flag IS_BACKGROUND_MUSIC should result in the earliest channel being deactivated, and if this should only affect FT demo or also the full game.

Any ideas?

Change History (3)

comment:1 by AndywinXp, 7 months ago

Summary: SCUMM: FT (demo): Two background music tracks playing a the same time in the intro videoSCUMM: FT (demo): Two background music tracks playing at the same time in the intro video

comment:2 by AndywinXp, 6 months ago

After some days of research it turns out we're currently handling SMUSH audio (for FT full and demo, and DIG demo) quite differently from the original. A PR which fixes this bug (and possibly other related ones) will be sent in a few days.

comment:3 by AndywinXp, 5 months ago

Owner: set to AndywinXp
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.