Opened 8 months ago

Closed 8 months ago

#13309 closed defect (fixed)

Crash: Marvel Comics Spider-Man: The Sinister Six (German version)

Reported by: windlepoons Owned by: windlepoons
Priority: blocker Component: Engine: Hypno
Version: Keywords: Crash
Cc: Game: Marvel Comics Spider-Man: The Sinister Six

Description

Go to Channel 2 Studios, at some step during the defense, ScummVM crashes.
Output from console:

scummvm: /data/src/common/list.h:148: void Common::List<T>::pop_front() [with t_T = unsigned int]: Assertion `!empty()' failed.

Attachments (1)

sinistersix-de.010 (10.2 KB ) - added by windlepoons 8 months ago.
Save game: Go to Channel 2 Studios

Download all attachments as: .zip

Change History (8)

by windlepoons, 8 months ago

Attachment: sinistersix-de.010 added

Save game: Go to Channel 2 Studios

comment:1 by neuromancer, 8 months ago

Interesting. Can you try to reproduce this issue playing directly the fight in training mode?

comment:2 by windlepoons, 8 months ago

Yes I can reproduce the crashes in training mode.
Training mode crashed:
Mysterio
Geier 2
Virtual Reality

scummvm: /data/src/common/list.h:148: void Common::List<T>::pop_front() [with t_T = unsigned int]: Assertion `!empty()' failed.

Mysterio 2 ends with

Invalid segment 2!
Debugger started, type 'exit' to return to the game.
Type 'help' to see a little list of commands and variables.
ERROR: Invalid segment 2!

comment:3 by neuromancer, 8 months ago

Please test https://github.com/scummvm/scummvm/commit/f6ea98a10ee105f75ccf5a87988d4596887b6a07 and let me know if any of these crashes.

Thanks!

comment:4 by windlepoons, 8 months ago

In the arcade of the save game (I think before I would have won) ScummVM stops with debugger console. Also in Trainigs mode Virtual Reality after a long fight.
The debugger console of ScummVM showed the following:

Invalid segment 2!
Debugger started, type 'exit' to return to the game.
Type 'help' to see a little list of commands and variables.
ERROR: Invalid segment 2!

I typed in the debugger console 'help' and then the variable 'debug_countdown' with the following result:

) debug_countdown
(int)debug_countdown = 0
)
Last edited 8 months ago by windlepoons (previous) (diff)

comment:5 by neuromancer, 8 months ago

I could not reproduce this issue (I tested your saved game and the virtual reality training), however, I found a crash when health reaches zero and fixed it in the my latest commit. Please update and re-test just in case this is related.

comment:6 by windlepoons, 8 months ago

Ok, I don’t have crash anymore, but the fight with Octopus has 2 bugs (new ticket).
→ fixed

comment:7 by windlepoons, 8 months ago

Owner: changed from neuromancer to windlepoons
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.