Opened 2 years ago

Closed 15 months ago

Last modified 15 months ago

#13304 closed defect (worksforme)

AGS: Heroine's Quest russian version is using latin font instead of cyrillic font (regression)

Reported by: lolbot-iichan Owned by: tag2015
Priority: normal Component: Engine: AGS
Version: Keywords: regression
Cc: Game:

Description

TESTCASE:

  1. Get ​https://store.steampowered.com/app/283880/Heroines_Quest_The_Herald_of_Ragnarok/
  2. Select Russian language

EXPECTED RESULT:
You see cyrillic text from Poetic Eda.

ACTUAL RESULT:
You see the same text, but in latin letters.

NOTE: Cyrillic font was displayed correctly previously, in time of creating #12594

Attachments (2)

image-20220219-155843.png (12.9 KB ) - added by lolbot-iichan 2 years ago.
image-20220219-155950.png (19.1 KB ) - added by lolbot-iichan 2 years ago.

Download all attachments as: .zip

Change History (6)

by lolbot-iichan, 2 years ago

Attachment: image-20220219-155843.png added

by lolbot-iichan, 2 years ago

Attachment: image-20220219-155950.png added

comment:1 by Crystal-Shard, 2 years ago

Hi there, I'm the author of Heroine's Quest. This is most likely an issue within HQ, not within SCUMMVM (I'm saying that because it looks similar to missing-translation or missing-font issues we've had in the past). I cannot reproduce this on the current build of the game; if it reoccurs in the future, please report over at Steam and I'll look into it.

Last edited 2 years ago by Crystal-Shard (previous) (diff)

comment:2 by tag2015, 18 months ago

Using the latest Steam version and the development version of ScummVM, localized texts seem fine. Can this be closed?

comment:3 by tag2015, 15 months ago

Owner: set to tag2015
Resolution: fixed
Status: newclosed

I can't reproduce this (setting the language to Russian or other languages containing special characters), using 2.7.0 stable or 2.8.0git.
There's a small issue when starting the game with Russian set in scummvm's GUI, the "Choose your language" localized string is missing some characters. But that also happens in the the original game (the "handwritten" font is probably missing those characters), so it's not a ScummVM bug.

Closing, please reopen if needed

comment:4 by tag2015, 15 months ago

Resolution: fixedworksforme
Note: See TracTickets for help on using tickets.