Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#13296 closed defect (fixed)

GROOVIE: TLC crashes on first interactive scene

Reported by: prietveld Owned by: Die4Ever
Priority: normal Component: Engine: Groovie
Version: Keywords: tlc tender loving care groovie crash
Cc: Game: Tender Loving Care

Description

Game version: US 4CD
ScummVM 2.6.0git3186-g756868ff30b (Feb 18 2022 05:15:46)

Immediately after (either watching or skipping) the intro, ScummVM crashes with:

[...]
Warning: Groovie::ROQ: Block 1020 Should have ended at 141686, and has ended at 141685!
Assertion failed: _pos <= _end, file /data/src/common/stream.cpp, line 265

This application has requested the Runtime to terminate it in an unusual way

Attachments (2)

scummvm.ini (1.1 KB ) - added by prietveld 8 months ago.
scummvm.log (2.8 KB ) - added by prietveld 8 months ago.

Download all attachments as: .zip

Change History (17)

comment:1 by Die4Ever, 8 months ago

I'm not able to reproduce this, can you attach the full log file?

if you're on windows then it's at %APPDATA%\ScummVM\

mac ~/Library/Preferences/ScummVM Preferences

linux ~/.config/scummvm/

(just realized I copy pasted with the config filename lol)

Last edited 8 months ago by Die4Ever (previous) (diff)

comment:2 by eriktorbjorn, 8 months ago

I can't reproduce this either, though I believe mine is a European release. (It says "Manufactured and distributed by FUNSOFT" on the box.)

comment:3 by eriktorbjorn, 8 months ago

I added some debugging messages to mine, and this is what I saw at the end after skipping the intro:

Groovie::ROQ: Block 1020 ended at 139834
Groovie::ROQ: Block 1020 ended at 140760
Groovie::ROQ: Block 1020 ended at 141685

Which is the same position that yours ended at, except in my case apparently that's what it expected.

Last edited 8 months ago by eriktorbjorn (previous) (diff)

by prietveld, 8 months ago

Attachment: scummvm.ini added

by prietveld, 8 months ago

Attachment: scummvm.log added

comment:4 by prietveld, 8 months ago

Added my log and ini files. Let met know if I should (and would be allowed to) share specific game files if that helps.

comment:5 by Die4Ever, 8 months ago

thanks for the log file

I feel like it might just be a corrupted video file

comment:6 by prietveld, 8 months ago

I tried the game in PCem, and it does work there. In ScummVM it crashes mid-voice over "I w..." on the screen with the parked car; in PCem it continues and I get the first of a set of multiple choice questions.

in reply to:  6 comment:7 by Die4Ever, 8 months ago

Replying to prietveld:

I tried the game in PCem, and it does work there. In ScummVM it crashes mid-voice over "I w..." on the screen with the parked car; in PCem it continues and I get the first of a set of multiple choice questions.

I think we just have more strict error-checking than the original game did, it might be possible to change this to a warning instead of an error so that it attempts to continue playing but it's possible that some of your other files might be slightly corrupted too

comment:8 by prietveld, 8 months ago

Perhaps someone else with a US copy could chime in to confirm whether it's the version or just my specific copy? Wouldn't make sense to cater for corrupt files.

in reply to:  8 comment:9 by Die4Ever, 8 months ago

Replying to prietveld:

Perhaps someone else with a US copy could chime in to confirm whether it's the version or just my specific copy? Wouldn't make sense to cater for corrupt files.

mine is USA

do you have the original modified dates for the files? my GROOVIE/TLCMAIN.GRV file is 1998-05-01

comment:10 by prietveld, 8 months ago

Same here

comment:11 by prietveld, 8 months ago

Update: originally, I copied all discs on top of each other in order, replacing duplicate files, effectively ending up with these files from disc 4. I now tried the same in reverse order, ending up with the shared files from disc 1- and no more errors.

I did re-download the latest daily ScummVM build, but unless the proposed fix was already implemented it seems the problem was with a file (or files) from disc 4. Maybe you could confirm with your copy if disc 4 has any differences in shared files?

comment:12 by Die4Ever, 8 months ago

Owner: set to Die4Ever
Resolution: fixed
Status: newclosed

you're right, the copying order does seem to matter here, I'll update the wiki to specify copying CD4 first, thank you!

comment:13 by prietveld, 8 months ago

Thanks. A last bonus question while I'm here: am I correct that from the SYSTEM folder only ICONS.PH and *.RLE are used, or are there any other files required later on in the game?

in reply to:  13 comment:14 by Die4Ever, 8 months ago

Replying to prietveld:

Thanks. A last bonus question while I'm here: am I correct that from the SYSTEM folder only ICONS.PH and *.RLE are used, or are there any other files required later on in the game?

I believe you are correct, just ICONS.PH (I think on Mac it's named ICONS.BIN) and the RLE file are required

Last edited 8 months ago by Die4Ever (previous) (diff)

comment:15 by Die4Ever, 8 months ago

I made this commit to try to make it easier to understand what the issue could be when this does happen

https://github.com/scummvm/scummvm/commit/83c801cd2116d2126d17c4a0ed8ef6078d98f37f

Note: See TracTickets for help on using tickets.