Opened 8 months ago

Closed 6 months ago

#13284 closed defect (invalid)

Leisure Suit Larry 3 DOS adds both DOS and Atari ST versions when scanned in mass add

Reported by: i30817 Owned by:
Priority: normal Component: --Unset--
Version: Keywords: Launcher
Cc: Game:

Description

Another one i'm unsure is a bug, since the data between the versions could be exactly the same, minus the executable and is only a question of configuration.

Please feel free to close this one if they're because of 'same data but scummvm can provide the experience of the different interpreters so the launcher adds both dos and atari versions'.

[lsl3]
platform=pc
gameid=lsl3
description=Leisure Suit Larry 3: Passionate Patti in Pursuit of the Pulsating Pectorals (DOS/English)
language=en
path=/media/i3/Mordred/Games/ScummVM/leisure_suit_larry_3
engineid=sci
guioptions=sndNoSpeech gameOption1 gameOption2 gameOption3 gameOption7 gameOptionE gameOptionH lang_English

[lsl3-st]
platform=atari
gameid=lsl3
description=Leisure Suit Larry 3: Passionate Patti in Pursuit of the Pulsating Pectorals (Atari ST/English)
language=en
path=/media/i3/Mordred/Games/ScummVM/leisure_suit_larry_3
engineid=sci
guioptions=sndNoSpeech gameOption1 gameOption2 gameOption3 gameOptionE gameOptionH lang_English

Change History (2)

comment:1 by i30817, 8 months ago

Summary: Leisure Suit Larry 3 DOS adds both DOS and Atari ST versions when scanned.Leisure Suit Larry 3 DOS adds both DOS and Atari ST versions when scanned in mass add

comment:2 by sluicebox, 6 months ago

Resolution: invalid
Status: newclosed

Thank you for the report. Both the detection and Mass Add are working as intended here.

The LSL3 detection entries are identical for both versions. Unfortunately, the only file that's different is RESOURCE.001 but the difference occurs after the first 5,000 bytes (which is what gets md5summed) and the file size is still the same. I believe that difference is just the text for the Atari ST credits. So they're effectively identical and choosing the platform is up to you. I believe the difference from the platform selection in LSL3 is music. (I just briefly tested it and that seems to be the case)

Mass Add intentionally adds all variants when it doesn't know what to do; the idea is that it can do its work unattended and you can remove ones you don't want afterwards:

// Just add all detected games / game variants. If we get more than one,
// that either means the directory contains multiple games, or the detector
// could not fully determine which game variant it was seeing. In either
// case, let the user choose which entries he wants to keep.

I had wondered if that was intentional too.

Note: See TracTickets for help on using tickets.