Opened 8 months ago

Closed 8 days ago

Last modified 8 days ago

#13282 closed defect (fixed)

KYRA: Lands of lore CD is being recognized as both several languages and several versions of the floppy game in mass add

Reported by: i30817 Owned by: athrxx
Priority: normal Component: Engine: Kyra
Version: Keywords: detection
Cc: Game: Lands of Lore

Description

This one is weird. I'm quite sure that it's probably a bug that there are 3 versions of 'english floppy' that point to what appears to be language subdirectories, but i'm not quite sure that it's impossible that the cd version is recognized as both floppy and cd.

[lol-cd]
platform=pc
gameid=lol
description=Lands of Lore: The Throne of Chaos (DOS/English)
language=en
extra=You added the game incorrectly. Please add the root folder of the game.
path=/media/i3/Mordred/Games/ScummVM/lands_of_lore_1/fre
engineid=kyra
guioptions=midiPCSpk midiAdLib midiMt32 midiGM vga lang_English

[lol-cd-1]
platform=pc
gameid=lol
description=Lands of Lore: The Throne of Chaos (DOS/English)
language=en
extra=You added the game incorrectly. Please add the root folder of the game.
path=/media/i3/Mordred/Games/ScummVM/lands_of_lore_1/eng
engineid=kyra
guioptions=midiPCSpk midiAdLib midiMt32 midiGM vga lang_English

[lol-cd-2]
platform=pc
gameid=lol
description=Lands of Lore: The Throne of Chaos (DOS/English)
language=en
extra=You added the game incorrectly. Please add the root folder of the game.
path=/media/i3/Mordred/Games/ScummVM/lands_of_lore_1/ger
engineid=kyra
guioptions=midiPCSpk midiAdLib midiMt32 midiGM vga lang_English

[lol-cd-3]
platform=pc
gameid=lol
description=Lands of Lore: The Throne of Chaos (CD/DOS/English)
language=en
extra=CD
path=/media/i3/Mordred/Games/ScummVM/lands_of_lore_1
engineid=kyra
guioptions=midiPCSpk midiAdLib midiMt32 midiGM vga gameOption4 gameOption5 gameOption8 lang_English

[lol-cd-4]
platform=pc
gameid=lol
description=Lands of Lore: The Throne of Chaos (CD/DOS/German)
language=de
extra=CD
path=/media/i3/Mordred/Games/ScummVM/lands_of_lore_1
engineid=kyra
guioptions=midiPCSpk midiAdLib midiMt32 midiGM vga gameOption4 gameOption5 gameOption8 lang_German

[lol-cd-5]
platform=pc
gameid=lol
description=Lands of Lore: The Throne of Chaos (CD/DOS/French)
language=fr
extra=CD
path=/media/i3/Mordred/Games/ScummVM/lands_of_lore_1
engineid=kyra
guioptions=midiPCSpk midiAdLib midiMt32 midiGM vga gameOption4 gameOption5 gameOption8 lang_French

Change History (7)

comment:1 by athrxx, 8 months ago

The first three entries are actually dummy entries which are supposed to prevent people from accidently adding one of the sub directories as a game target (that's why they have that error message in the extra field).

But of course the 'mass add' feature shouldn't add these either.

We'll have to filter these somehow during the mass add detection.

The last three entries seem to work as intended.

comment:2 by i30817, 8 months ago

Summary: Lands of lore CD is being recognized as both several languages and several versions of the floppy gameLands of lore CD is being recognized as both several languages and several versions of the floppy game in mass add

comment:3 by digitall, 5 months ago

Component: --Unset--Engine: Kyra
Game: Lands of Lore
Keywords: detection added; Launcher removed
Summary: Lands of lore CD is being recognized as both several languages and several versions of the floppy game in mass addKYRA: Lands of lore CD is being recognized as both several languages and several versions of the floppy game in mass add

comment:4 by athrxx, 3 weeks ago

Could you please check whether you find this particular bug still valid? There have been improvements on the mass add function, but I am not sure if they address this one.

comment:5 by i30817, 8 days ago

Yes i can do that. I just built scummvm git master 9400519896d708f3594e2a9c259eb57e69a1572b

and checked by removing lands of lore from my list and adding again.

It just added the 3 languages in the cd, so i guess this one is fixed.

comment:6 by digitall, 8 days ago

Owner: set to digitall
Resolution: fixed
Status: newclosed

comment:7 by digitall, 8 days ago

Owner: changed from digitall to athrxx
Note: See TracTickets for help on using tickets.