Opened 3 years ago

Closed 17 months ago

#13227 closed defect (outdated)

MYST3: Crash in Voltaic Age - DVD Variant

Reported by: zephiiyr Owned by: lotharsm
Priority: high Component: Engine: Myst3
Version: Keywords:
Cc: Game: Myst 3: Exile

Description

Game has been completely functional up to this point (been playing for a few hours), but crashes instantly the second I step forward to one specific place in Voltaic.
ScummVM's console reads 'ERROR: Face 28 does not exist!' when this happens.
This happens consistently and there's no apparent way around it.

Myst III Exile (DVD/Windows/English)
MacOS 10.9.5
ScummVM 2.5.1
(Crash happens in the Steam release version as well)

Attachments (2)

8.M3S (89.3 KB ) - added by zephiiyr 3 years ago.
Screen Shot 2022-01-17 at 4.07.43 PM.png (211.7 KB ) - added by zephiiyr 3 years ago.

Download all attachments as: .zip

Change History (9)

by zephiiyr, 3 years ago

Attachment: 8.M3S added

comment:1 by macca8, 3 years ago

Component: --Unset--Engine: Myst3

I've tested your saved game on macOS 10.11.6 with both the v2.5.1 32-bit & 64-bit releases, and can't reproduce this issue after tracking back and forth along the full length of the designated path identified in your save.

I'm using the original 4-CD US (English only) version - v1.0, updated to v1.22 - so perhaps it's restricted to your DVD version.

Is your DVD the Windows 10th anniversary edition (a hybrid Windows/Mac disc)? Is the Steam version the 25th anniversary release?

My understanding is that the 25th anniversary release is just a re-release of the old Windows 10th anniversary DVD version (compatible with macOS 10.13 & later as a standalone release), so it would make sense to see the same error in both versions.

comment:2 by digitall, 3 years ago

Summary: Myst 3 Voltaic crashMYST3: Crash in Voltaic Age - DVD Variant

comment:3 by digitall, 3 years ago

That engine error originates from here:
https://github.com/scummvm/scummvm/blob/master/engines/myst3/nodecube.cpp#L38

zephiiyr: Looking at the code and the logs, I think we would need someone with this game version to try running this and doing the following:

  1. Go close to the bugged node point and do CTRL-ALT-D to open the debug console.
  2. type "infos" and paste the output here as a text file attachment
  3. type "debuglevel 5" and "debugflag_enable script". This enables debug output for the script parsing.
  4. Hit the bugged node and paste the script debug output here as a text file attachment.

That should give the MYST3 engine developers a good idea what is happening with your version.

comment:4 by antoniou79, 2 years ago

I could test on Windows 10 Pro x64 (21H2 build 19044.1466) with GOG and Steam versions of the game, with 2.5.1 (official release binary via scummvm-2.5.1-win32-x86_64.zip) and a local build from current master (2.6.0git). I am unable to reproduce a crash on these versions, walking along the path either further into the cave or towards the outside.

The Steam release of the game comes with ResidualVM (0.3.2pre), and includes a residualvm-override.ini where the game's description is "Myst III Exile (25th Anniversary)" and a myst3.ini with a section for each of the available languages. Inside the latter, the game is described as "Myst III Exile (DVD/Windows/English)" (or /French, /Dutch, /German, /Italian etc). I did not have to install any patch for it to work with ScummVM.

The GOG release of the game comes with ResidualVM (0.3.1), and includes a myst3.ini where the game is described as "Myst III Exile (DVD/Windows/English)". No extra patch was needed her either. No indication that this is the 25th Anniversary, but I am quite sure it is, which is further verified by this thread on the GOG forum: https://www.gog.com/forum/myst_series/myst_25th_anniversary

ScummVM detects both as "Myst III Exile (DVD/Windows/English)" without any qualifier to indicate a difference between GOG and Steam versions.

Last edited 2 years ago by antoniou79 (previous) (diff)

comment:5 by lephilousophe, 18 months ago

Is this bug still valid?
Steam version seems to work unlike what has been described in the original bug report.

comment:6 by Thunderforge, 17 months ago

Tried with ScummVM 2.7.0pre on macOS 13.1 using the DVD version that the Readme file identifies as

Version 1.27 for Windows 95 / 98 / ME / XP and Mac OS 8.1 or 9.1 or OS 10.1
July 21, 2003

Per the instructions for data files, I copied language.m3u to M3Data/TEXT/ENGLISH.m3u.

Loading the save game, I can't reproduce the bug. I also started a fresh game, went to the Voltaic Age, and got to the same spot. Still can't reproduce the bug.

It seems the original poster is the only one able to reproduce this. If we can't get any more info, then maybe it needs to be closed as unreproducible.

If the original poster still can reproduce it, I think we need more info about which DVD version exactly is being used (and which language, since that's the only other variable I can think of).

Last edited 17 months ago by Thunderforge (previous) (diff)

comment:7 by lotharsm, 17 months ago

Owner: set to lotharsm
Resolution: outdated
Status: newclosed

I'm going to close this for now.

We got multiple reports that the versions currently available on Steam, GOG and Thunderforge's DVD version, and were unable to reproduce the bug. Feedback was requested two weeks ago as well, but we didn't got a reply.

Closing this as "outdated".

Note: See TracTickets for help on using tickets.