Opened 6 months ago

Closed 6 months ago

#13209 closed defect (fixed)

SCI - LSL7 Russian: Fatal error after giving polyester to Jamie

Reported by: m0003r Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords: original
Cc: Game: Leisure Suit Larry 7

Description (last modified by m0003r)

Game version: LSL7 Softclub/DOS/Russian
Affected ScummVM versions: 2.5.1, 2.6@e843e6447

Scene with Peggy near cabin 0 is defective (two animations overlapping), but playable.

After screen dimming debugger opens with message:
kAddScreenItem: Plane 0000:0000 not found for screen item 0066:08dc
and game stops working.

*UPD:* sometimes bug occurs little earlier (during scene with Peggy, see attached video)

I have patched engine, replacing error with warning with return and the patch works (game can be completed).

I don't know if that way of patching is correct.

Attachments (4)

lsl7-ru.029 (82.7 KB ) - added by m0003r 6 months ago.
lsl7.patch (1.4 KB ) - added by m0003r 6 months ago.
Leisure Suit Larry 7_ Love for Sail! (Softclub_DOS_Russian).mp4 (1.3 MB ) - added by m0003r 6 months ago.
lsl7-ru.002 (80.5 KB ) - added by sluicebox 6 months ago.

Download all attachments as: .zip

Change History (13)

by m0003r, 6 months ago

Attachment: lsl7-ru.029 added

by m0003r, 6 months ago

Attachment: lsl7.patch added

comment:1 by m0003r, 6 months ago

Description: modified (diff)

comment:2 by m-kiewitz, 6 months ago

Description: modified (diff)

we don't download anything from anywhere

comment:3 by m0003r, 6 months ago

Description: modified (diff)

I'm sorry, removed PS completely

comment:4 by bluegr, 6 months ago

Summary: Fatal error after giving polyester to JamieSCI - LSL7 Russian: Fatal error after giving polyester to Jamie

comment:5 by sluicebox, 6 months ago

Hello! Thanks for reporting this error. I can now reproduce this and will take a closer look soon.

Last edited 6 months ago by sluicebox (previous) (diff)

comment:6 by m0003r, 6 months ago

Description: modified (diff)

comment:7 by m0003r, 6 months ago

Hello! Thank you!
I have also attached a video with the bug just in case

comment:8 by sluicebox, 6 months ago

I'm still working on this, but in the meantime, I'm attaching a fixed version of your save file so that you can keep playing.

You can also apply this workaround yourself with the ScummVM debugger (CTRL+ALT+D) by entering the case-sensitive command: send MouthSync oSpecialSync 0

by sluicebox, 6 months ago

Attachment: lsl7-ru.002 added

comment:9 by sluicebox, 6 months ago

Keywords: original added
Owner: set to sluicebox
Priority: blockernormal
Resolution: fixed
Status: newclosed

Fixed in https://github.com/scummvm/scummvm/commit/e0a7df681d8cbfd95f99cb8fd66f2d8b7acfff8d

This will appear in the next daily build.

This fix prevents the game from getting in the broken state. That occurs when talking to Peggy outside. It won't instantly fix existing save games that are already in that state, but you can fix those by simply talking to Peggy outside.

Thanks again for reporting this. Setting priority to normal since this is a script bug in the original game that only occurs in certain situations.

Note: See TracTickets for help on using tickets.