Opened 5 months ago

Last modified 2 months ago

#13204 new defect

Alice Interactive Museum (Director 2/4?) Loading Issue

Reported by: mystrw1 Owned by:
Priority: normal Component: Engine: Director
Version: Keywords:
Cc: Game:

Description (last modified by mystrw1)

Game-Alice An Interactive Museum
ScummVM version-2.6 (built 12/27/21, 14:36:45)
Game Engine-Director 2/4
Language-English
Game version-
My OS-Win 10
This comment may be too early since Director is still early in development but I had the game available and decided to try it out. Alice Interactive Museum appears to be properly detected when the game/files are added to ScummVM. Then, after clicking the Start button, a black screen appears with a functioning mouse cursor. Game appears to stall here. I also note the following info./warning messages (repeating continuously...)

WARNING: BUILDBOT: Uncaught Lingo error: Call to undefined handler 'Widget'. Dropping 1 stack items!
WARNING: varFetch: global variable drv not defined!
WARNING: Movie :DATA:OPENING:OPEN01.DIR does not exist!
WARNING: Lingo::setTheEntity(): Unprocessed setting entity exitLock!
WARNING: varFetch: variable mnew not found!

Change History (2)

comment:1 by rvanlaar, 2 months ago

Description: modified (diff)

Thank you for creating this bug report.

For now, try copying the data directory to the same directory as the as the .exe is found in.

The V4 version needs the external Xobject 'Widget', which is not implemented.

comment:2 by mystrw1, 2 months ago

Description: modified (diff)

Thank you. Moving the data files/folders worked to get the game started. The game ran thru entering the room with the water leak, finding the bookcase and opening the "linking" book to the artist's office. The book did not "link" though. (Is this where the Xobject Widget is needed...?)

Also, just as FYI, I ran the game under PCem to note any differences between it & SCUMM run and found the following...:

  • Opening credits did not run under SCUMM as seen under PCem.
  • No sound during painting "appearance" scene under SCUMM as heard under PCem.
  • As metioned above, book did not "link" to artists office under SCUMM as it did under PCem.
  • CTRL-Q did not work to exit game under SCUMM (CTRL-Z did work...) as it did under PCem.

Again, hope this addit. info. might be helpful in future...

Note: See TracTickets for help on using tickets.