Opened 8 months ago

Closed 7 months ago

#13193 closed defect (fixed)

BURIED: Arthur still visible after being lost from Biochip Inventory

Reported by: jamie-marchant Owned by: bluegr
Priority: normal Component: Engine: Buried
Version: Keywords:
Cc: Game: Journeyman Project 2: Buried in Time

Description (last modified by jamie-marchant)

Steps to reproduce:

  1. Get the Environ Cartridge from the CHICHEN ITZA underground.
  2. Insert it in the system in Gage's apartment. (with the lens off).
  3. Turn on the lens
  4. After the cutscene(you can skip it), save.
  5. Select Arthur.(with Control + A)
  6. When prompted type "Gravball" without looking at the files biochip.
  7. Arthur reminds visible onscreen, even though the chip is now blank. (see the screenshot)

Attachments (3)

Screenshot_2021-12-31_17-32-01.png (453.3 KB ) - added by jamie-marchant 8 months ago.
buried.002 (17.4 KB ) - added by jamie-marchant 8 months ago.
Screenshot_2022-01-03_14-15-05.png (495.5 KB ) - added by jamie-marchant 7 months ago.

Download all attachments as: .zip

Change History (17)

by jamie-marchant, 8 months ago

comment:1 by jamie-marchant, 8 months ago

Changing to another biochip(even blank) makes him disappear.

comment:2 by digitall, 8 months ago

Description: modified (diff)
Summary: Barrid: Author stays viable after you loose himBURIED: Arthur still available after being lost from Biochip Inventory

comment:3 by digitall, 8 months ago

jamie-marchant: Please can you attach a savegame with the Environ Cartridge in Gage's Apartment and the Lens prior to the Cutscene so the BURIED engine developers can investigate this? Thanks.

comment:4 by digitall, 8 months ago

Description: modified (diff)

comment:5 by digitall, 8 months ago

Summary: BURIED: Arthur still available after being lost from Biochip InventoryBURIED: Arthur still visible after being lost from Biochip Inventory

comment:6 by jamie-marchant, 8 months ago

Description: modified (diff)

by jamie-marchant, 8 months ago

Attachment: buried.002 added

comment:7 by jamie-marchant, 8 months ago

Ok, thankfully I kept a backup before leaving. The save game should be called "Jamie". I've also slightly modified my steps to reproduce.

comment:8 by digitall, 8 months ago

Yes, I can now replicate the issue from your savegame.

comment:9 by digitall, 8 months ago

Owner: set to digitall
Resolution: fixed
Status: newpending

Fix applied as commit https://github.com/scummvm/scummvm/commit/7bb707e986bece461aae26b43debaa5fc9bbc3cf.

jamie-marchant: Please test and confirm with the next nightly build which will include
this fix: https://buildbot.scummvm.org/#/dailybuilds

comment:10 by jamie-marchant, 7 months ago

Buildbot does not have Fedora Core builds and it took 30 minutes to compile a daily build the first time. I don't have time for this tonight. (not sure if Make has a cache)

Before I test it, I can see looking at the source code, your fix will fix my issue but cause a "strange issue" for most users. You see, I have played the game a bunch of times before and memorized the correct password to enter(so I selected Arthur to see him disappear), most players will have the "files" Biochip active to find the password. Your new source code will set it to a blank(for no good reason) when they give the correct code. The correct solution is an if statement to see if Arthur is active and change it to blank if it is.

in reply to:  10 comment:11 by bluegr, 7 months ago

Owner: changed from digitall to bluegr
Status: pendingclosed

Thanks for the fix digitall, and thanks for the report and additional comments jamie-marchant!

An improved version of this fix that also checks if Arthur was selected before sacrificing himself has been done in commit 74f2df71c30f4f1e0bb9419bedb8b6b222708212:
https://github.com/scummvm/scummvm/commit/74f2df71c30f4f1e0bb9419bedb8b6b222708212

Closing

comment:12 by jamie-marchant, 7 months ago

Is the change here: https://github.com/scummvm/scummvm yet? If so, I noticed new bug as a result of this change. With this change, if your on the files Biochip, now suddenly the blank chip is selected(rather then the files one). I've attached a screenshot.(It is Linux, just with a Windows 95 window theme).

Last edited 7 months ago by jamie-marchant (previous) (diff)

by jamie-marchant, 7 months ago

comment:13 by jamie-marchant, 7 months ago

Resolution: fixed
Status: closednew

comment:14 by bluegr, 7 months ago

Resolution: fixed
Status: newclosed

When Arthur sacrifices himself in Agent 3's lair, the steps performed are the following:

  • Arthur's biochip is removed from the inventory
  • The blank chip is added to the inventory
  • The current inventory item is set to the currently added one (this is what happens when a new item is added)
  • If Arthur's biochip was previously shown on the right, the blank chip will be shown on the right instead (that's what has been done in this fix)

Both of these issues are present in the original. In this specific scene, there is an action which occurs asynchronously (Arthur's chip being destroyed and replaced with a blank chip). While this happens, the player is free to perform any sort of action, and when Arthur finishes his speech, the scripted event occurs.

We fixed the biochip shown on the right, but it's not easy to fix the selection of the inventory item without adding workarounds for specific cases that I wouldn't want to add. The inventory is updated with the blank biochip, and if the player has the files screen open, he is supposed to see that. Opening the files screen while listening to Arthur dying is surely an edge case, and I don't see any benefit to add workarounds for changing the currently selected item in this scene with specific item combinations, because we might introduce other unwanted bugs and side effects, for no real gain.

Thus, I'm closing this bug again - we haven't introduced a regression with our changes, and we don't need to mess up with core game logic and introduce other potential bugs for no real gain.

Note: See TracTickets for help on using tickets.