Opened 6 months ago

Closed 5 months ago

#13175 closed defect (worksforme)

TITANIC: Can't get Bar Bot to add the Vodka

Reported by: jamie-marchant Owned by: dreammaster
Priority: normal Component: Engine: Titanic
Version: Keywords:
Cc: Game: Starship Titanic

Description

I can't get Bar Bot to add the Vodka. I have included my save game and a screenshot.

Attachments (3)

2021-12-27 13_26_42-Window.png (263.8 KB ) - added by jamie-marchant 6 months ago.
titanic-win.000 (105.1 KB ) - added by jamie-marchant 6 months ago.
titanic-win.001 (105.0 KB ) - added by jamie-marchant 6 months ago.

Download all attachments as: .zip

Change History (8)

by jamie-marchant, 6 months ago

by jamie-marchant, 6 months ago

Attachment: titanic-win.000 added

by jamie-marchant, 6 months ago

Attachment: titanic-win.001 added

comment:1 by jamie-marchant, 6 months ago

This is on daly build(Dec 27th/21) on Windows 10

comment:2 by bluegr, 6 months ago

Summary: Can't get Bar Bot to add the VodkaTITANIC: Can't get Bar Bot to add the Vodka

comment:3 by jamie-marchant, 6 months ago

On another ticket, I said I ran Linux but I tested on my Windows installation as that was the fastest way to test on a daily build. I hope that cleverfies any confusion.

in reply to:  3 comment:4 by jamie-marchant, 6 months ago

Replying to jamie-marchant:

On another ticket, I said I ran Linux but I tested on my Windows installation as that was the fastest way to test on a daily build. I hope that cleverfies any confusion.

Ignore this I decided I want to test the daily builds of Buried In Time, so compiled a "daily build" on Linux and will be using that to test on now.

comment:5 by dreammaster, 5 months ago

Owner: set to dreammaster
Resolution: worksforme
Status: newclosed

Sorry for the delay, I finally had a chance to check out your savegame. And I think it's all working as intended. By the games logic, the vodka has to be added as the last ingredient, and in your savegame you hadn't yet given him the starling puret. When I generated it and gave it to him, and then told him to add it in, I was then able to ask him to add vodka, and the recipe was complete.

Note: See TracTickets for help on using tickets.