Opened 9 months ago

Closed 9 months ago

#13172 closed feature request (fixed)

BURIED: Hide mouse pointer during cutscenes

Reported by: jamie-marchant Owned by: bluegr
Priority: normal Component: Engine: Buried
Version: Keywords:
Cc: Game: Journeyman Project 2: Buried in Time

Description

Hi

Please hide the mouse pointer during cutscenes in Buried In Time, I know you are emulating the original game but I consider the mouse pointer at all times to be a limitation of the game(which did not use DirectX) and not a "design decision".

-Jamie Marchant

Change History (6)

comment:1 by bluegr, 9 months ago

Summary: Hide Mouse Pointer in Barried In TimeBURIED: Hide mouse pointer during cutscenes

comment:2 by bluegr, 9 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

Implemented in commit 889070f479edf0d87237ff276b181636cd894e50:
https://github.com/scummvm/scummvm/commit/889070f479edf0d87237ff276b181636cd894e50

I've done a full playthrough with this and everything works as expected

Closing

comment:3 by jamie-marchant, 9 months ago

Resolution: fixed
Status: closednew

This works for me but not very often, mainly for flythroughs.

comment:4 by bluegr, 9 months ago

Resolution: fixed
Status: newpending

Please be more specific. What doesn't work for you? The cursor is hidden in cutscenes, and it shows up as a hourglass in the other scenes.

Setting this to pending until more specific information it provided, ideally together with a saved game

comment:5 by jamie-marchant, 9 months ago

Oh, I see, you and I define a cutscene differently. I was thinking instead of an hourglass for other things, you would just not see the cursor at all.

The timmer would be for loading assets.

comment:6 by bluegr, 9 months ago

Status: pendingclosed

The change affects cases where the cursor is an arrow can be hidden completely (e.g. full screen videos) . Cases where the cursor shows as an hourglass have not been changed, as this behavior is by design.

Closing

Note: See TracTickets for help on using tickets.