Opened 9 months ago

Closed 8 months ago

#13167 closed defect (fixed)

TWINE: Doors are not working sometimes

Reported by: vvs- Owned by: mgerhardy
Priority: high Component: Engine: TwinE
Version: Keywords:
Cc: Game: Little Big Adventure

Description

On Proxyma Island the same doors sometimes might open in different directions and become stuck. I don't know yet why.

Attachments (7)

scummvm-lba-cd-00003.png (224.2 KB ) - added by vvs- 9 months ago.
scummvm-lba-cd-00004.png (224.2 KB ) - added by vvs- 9 months ago.
scummvm-lba-cd-00005.png (223.7 KB ) - added by vvs- 9 months ago.
scummvm-lba-cd-00006.png (225.2 KB ) - added by vvs- 9 months ago.
scummvm-lba-cd-00007.png (467.2 KB ) - added by vvs- 9 months ago.
scummvm-lba-cd-00000.png (171.3 KB ) - added by vvs- 9 months ago.
Using vertically moving gratings
lba-de.000 (12.4 KB ) - added by mgerhardy 8 months ago.

Download all attachments as: .zip

Change History (19)

comment:1 by mgerhardy, 9 months ago

Do you have a screenshot and maybe a savegame for me? would help to identify the scene id and the debugging.

comment:2 by mgerhardy, 9 months ago

Priority: normalhigh

comment:3 by mgerhardy, 9 months ago

Proxima island has a lot of scenes

Proxima_Island_Proxim_City = 42,
Proxima_Island_Museum = 43,
Proxima_Island_near_the_Inventors_house = 44,
Proxima_Island_upper_rune_stone = 45,
Proxima_Island_lower_rune_stone = 46,
Proxima_Island_before_the_upper_rune_stone = 47,
Proxima_Island_Forgers_house = 48,
Proxima_Island_Prison = 49,
Proxima_Island_Shop = 50,
Proxima_Island_Sewer = 51,
Proxima_Island_Grobo_house = 53,
Proxima_Island_Inventors_house = 54,

you can open the debug console and change the scene with

change_scene <id>

if you found the door, please make a screenshot.

by vvs-, 9 months ago

Attachment: scummvm-lba-cd-00003.png added

by vvs-, 9 months ago

Attachment: scummvm-lba-cd-00004.png added

by vvs-, 9 months ago

Attachment: scummvm-lba-cd-00005.png added

by vvs-, 9 months ago

Attachment: scummvm-lba-cd-00006.png added

by vvs-, 9 months ago

Attachment: scummvm-lba-cd-00007.png added

comment:4 by vvs-, 9 months ago

I've attached several screenshots in scenes 42 and 44 demonstrating wrong door positions. They can't fully open in that state. That happens with many doors on Proxyma Island but unfortunately I didn't figured out pattern to trigger it. It looks pretty random and they might work correct as well.

comment:5 by mgerhardy, 9 months ago

I've entered both scenes a few times and could not reproduce it. Does it happen often for you?

There are a few fixes that needs more testing in this pull request: https://github.com/scummvm/scummvm/pull/3633/

I've also fixed some angle related stuff in there - maybe this already fixes the issue.
But it's impossible to say whether I've fixed it by accident without being able to reproduce it. Any more hints are welcome. Everything might help.

And thanks a lot for your reports.

by vvs-, 9 months ago

Attachment: scummvm-lba-cd-00000.png added

Using vertically moving gratings

comment:6 by vvs-, 9 months ago

I think that I found a way to trigger this bug. It always happen to me after using vertically moving gratings, especially the one on the attached screenshot. After that some other gates and doors break and start to move vertically instead of horizontally.

comment:7 by mgerhardy, 9 months ago

this is the proxima island prison with scene id 49

by mgerhardy, 8 months ago

Attachment: lba-de.000 added

comment:8 by mgerhardy, 8 months ago

attached savegame to reproduce it - load it, use change_scene 50 - leave the room and enter the next door.

comment:9 by mgerhardy, 8 months ago

no, doesn't work - when loading the attached savegame the bug doesn't appear. You have to:

change_scene 49
leave the scene into the underground
toggle_freecamera and c and v to spawn next to the other lift
toggle the lift to enter scene 49 again from another entrace - now the doors are broken.
change_scene 50
pick the door at the upper left side of twinsen and open it.

comment:10 by mgerhardy, 8 months ago

processActor.y in Animations::processActorAnimations is somehow getting wrong...

comment:12 by mgerhardy, 8 months ago

Owner: set to mgerhardy
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.