Opened 8 months ago

Closed 3 months ago

#13155 closed defect (fixed)

AGI: Mickey's Space Adventure Detection Problem

Reported by: dshell102 Owned by: antoniou79
Priority: normal Component: Engine: AGI
Version: Keywords: detection
Cc: dshell102 Game:

Description

It was working fine and we were well into the game. I did the update yesterday...then I get error messages and it comes up as a Mickey Holiday game now.

The game in 'Mickeys Space Adventure\' seems to be an unknown game variant.

Please report the following data to the ScummVM team at https://bugs.scummvm.org/ along with the name of the game you tried to add and its version, language, etc.:

Matched game IDs for the director engine: ssholidaymickey-win

{"mickey.exe", 0, "47838dc415a783ab790ad2161b97937f", 55136},

Change History (9)

comment:1 by digitall, 8 months ago

Component: --Unset--Engine: AGI
Keywords: detection added
Summary: Mickey's Space AdventureAGI: Mickey's Space Adventure Detection Problem

Mickey's Space Adventure is a Pre-AGI game and should be detected by the AGI engine
using the following:
https://github.com/scummvm/scummvm/blob/master/engines/agi/detection_tables.h#L526

dshell102: Do you have the files "1.pic" and "FLASHLIT.OOO" in the game data directory?

The message emitted is a fallback detection from the DIRECTOR engine which is triggered by the "mickey.exe" file, but the AGI detection table entry should match first...

comment:2 by digitall, 8 months ago

Hmm.. The fallback is being triggered by the entry added here:
https://github.com/scummvm/scummvm/commit/62b4176ee3b2722ffac2f4711bbefbff785e0fc0#diff-d2635d738a260423870cd11b600e96d27870e6d86bf0c03b5dbbfa65312a0d52R3583

dshell102: You should be able to run the detection and select between Mickey's Space Adventure and this fallback detection in the GUI popup?

comment:3 by digitall, 8 months ago

dshell102: See https://docs.scummvm.org/en/v2.5.0/use_scummvm/add_play_games.html
Specifically the section "Sometimes, ScummVM detects multiple versions of a single game. In this case, highlight the correct version and click Choose to continue." ...

comment:4 by dshell102, 8 months ago

I have both files mentioned. 1.pic is in the main directory and flashlit.ooo is in the obj folder.
When I try running the game it says "error running game: game data not found".

I installed an older version - 2.2.0 - and it works fine, save game and all.

comment:5 by dshell102, 8 months ago

digitall - unfortunately it's not finding multiple versions this time.
It's strange how it won't run. I did try deleting it, putting it back and finding it again and that's when it found the other version...no options to select between versions.

Installing the old version works fine - it's something with the update. Bizarre. I recommend testing it yourself, if possible, to see if you're getting the same thing. Especially where it works with 2.2.0 and not with 2.5.0.

Thank you for trying!

comment:6 by digitall, 8 months ago

dshell102: Ah, I have worked out the cause. It is this change:
https://github.com/scummvm/scummvm/commit/89f92a007ad2c6180acc125f81d0a02b13beeb49

This tightened up the detection entry to require the FLASHLIT.OOO file for detection.

However, that expects that all required datafiles are in a single directory i.e. no OBJ sub-directory rather than the original directory structures.

For now you can move your files into a single folder to avoid this issue with newer versions of ScummVM.

We can normally support the original subdirectory structures, but this may not be easy
with the AGI engine.

comment:7 by antoniou79, 3 months ago

After looking into the same issue for a new forum thread:
https://forums.scummvm.org/viewtopic.php?p=97149#p97149

I've posted my finding in that thread:
https://forums.scummvm.org/viewtopic.php?p=97149#p97149

and on Discord:
https://discord.com/channels/581224060529148060/711242520415174666/979632364982501406

It seems that the game engine expects the file "FLASHLIT.OOO" to be in its proper "OBJ" subfolder too. And the same goes for all the files in the "DAT" subfolder. Otherwise the game hard locks soon into the game intro (as reported in the forum thread referenced above).

So, the quick solution is to keep "OBJ" and "DAT" subfolders in the game data folder with their files intact *and also* have a copy of "FLASHLIT.OOO" in the game data folder too.

If this is the expected game folder structure, we should update the wiki with these instructions.

I am unsure if other preAGI / AGI games also have such issues -- but it's possible, in which case their instructions should also be updated.

comment:8 by antoniou79, 3 months ago

As suggested by criezy on Discord, it seems that a potential solution would be to set the folder search depth to 2 for the Advanced Detector and specify subdirectory, which would remove the requirement to have a copy of FLASHLIT.OOO outside its OBJ folder.

Quote:

There are two things to do:

  1. Set the _maxScanDepth to 2 (or more)
  2. And specify the subdirectory either in _directoryGlobs or in the detection entry. The latter also requires using the kADFlagMatchFullPaths flag.

PR opened here: https://github.com/scummvm/scummvm/pull/3916

Last edited 3 months ago by antoniou79 (previous) (diff)

comment:9 by bluegr, 3 months ago

Owner: set to antoniou79
Resolution: fixed
Status: newclosed

The PR has been merged, so this can be closed now. Thanks!

Note: See TracTickets for help on using tickets.