Opened 10 months ago

Closed 9 months ago

#13150 closed defect (fixed)

MOHAWK/QT: Crash in Riven Quicktime Video

Reported by: Gamellieur Owned by: sluicebox
Priority: normal Component: Engine: Mohawk
Version: Keywords: Quicktime
Cc: GamellieurGamellieur Game: Riven

Description

Goodmorning,
I'm playing Riven on a Windows 10 last updated pc, scummvm 2.5 version. Riven is in the 5 cd version I arrive at the third island with the funicolar railway on the left side, when I get the right side and click on the button to turn the cabin everything crush and appears that error:

ERROR: Unsupported QTRLE bits per pixel 0!\\

I suspect Scummvm can't support this Quicktime...
I have the savefile, if I understand how to add it.

Thanks a lot

Attachments (1)

riven-000.rvn (19.3 KB ) - added by Gamellieur 10 months ago.

Download all attachments as: .zip

Change History (7)

by Gamellieur, 10 months ago

Attachment: riven-000.rvn added

comment:1 by eriktorbjorn, 10 months ago

So, just to make sure I understand correctly, simply loading the savegame and pushing the blue button makes the game crash for you?

I can't reproduce this with my English CD version. I don't know which version you have, but surely these particular videos would be identical across versions?

Sometimes mysterious crashes are caused by the data files being corrupted. I don't know which file that would be in this case, though. You could try copying them from your CDs again, just to make sure.

comment:2 by sluicebox, 10 months ago

I may have fixed this last month: https://github.com/scummvm/scummvm/commit/d5f6d2543fe8e638730c09445cf049a184703425

That fix was for a bug in our decoder that caused a QuickTime video in a Director game to produce the exact same error message.

If I understand this right, you're using the 2.5.0 release. Can you please try this with our daily build to see if that fixes this?

Daily builds packaged in installers: ​https://www.scummvm.org/downloads/#daily
Daily builds packaged in zip files: ​https://buildbot.scummvm.org/#/dailybuilds

comment:3 by macca8, 10 months ago

FWIW, I'm running the 5-CD English-only version on macOS. I've tested the attached saved game with the latest 32-bit & 64-bit 2.5.0 releases, 2.5.1pre & 2.6.0git daily builds, and I'm not reproducing this issue with any of them... this includes pressing the button on this pedestal, rotating the cabin using the internal controls, and repeating the action with the pedestal on the opposite platform.

I note however, that the savename for the attached saved game is non-English (Italian perhaps?), so perhaps this issue is limited to that particular language version?

comment:4 by sluicebox, 10 months ago

I was wondering how it was possible that no one had reported until now that a Riven video crashed the decoder. That bug wasn't a regression either, the decoder had never worked when presented with a video with a color depth of 32. I even wrote in the commit message: "presumably no Mohawk movies had color depth 32"

But if this only affected a localized version, it makes sense. And we know that Riven has different QuickTime videos for localized versions because we have a workaround for an unrelated problem with a video in a Spanish version.

[ I feel compelled to point out that I don't know anything about the Mohawk engine and I've never even played these games; but I foolishly fixed a QuickTime bug for *one* SCI video and it led to another and now here we are... ]

comment:5 by digitall, 10 months ago

Cc: GamellieurGamellieur added; Gamellieur removed
Owner: set to sluicebox
Resolution: fixed
Status: newpending
Summary: Riven- Quicktime bugMOHAWK/QT: Crash in Riven Quicktime Video

Gamellieur: Please can you test with a daily build and see if this has fixed the issue you have identified? https://buildbot.scummvm.org/#/dailybuilds

comment:6 by sluicebox, 9 months ago

Status: pendingclosed

Patience expired!

Note: See TracTickets for help on using tickets.