Opened 5 months ago

Last modified 5 months ago

#13142 pending defect (assigned)

ASYLUM: Flickering savegame thumbnails

Reported by: George22x Owned by: alxpnv
Priority: normal Component: Engine: Asylum
Version: Keywords:
Cc: Game: Sanitarium

Description

Savegame thumbnails were often flickering in the menu of Sanitarium.

Attachments (5)

Sanitarium flickering save.m4v (430.3 KB ) - added by George22x 5 months ago.
1.jpg (45.5 KB ) - added by George22x 5 months ago.
2.jpg (40.1 KB ) - added by George22x 5 months ago.
3.jpg (48.4 KB ) - added by George22x 5 months ago.
4.jpg (46.5 KB ) - added by George22x 5 months ago.

Download all attachments as: .zip

Change History (12)

comment:1 by digitall, 5 months ago

George22x: Thanks for your bug report, but can you provide some further information as per the bug tracker front page as follows:

Please check you are including all the following information in your bug report:

ScummVM version (scummvm -v)
Bug details, including step-by-step instructions to reproduce the bug
Language of game (English, German, ...)
Version of game (CD, Floppy, DOS, Amiga, ...)
Your OS, including version and device if appropriate (Windows 10 build 1709 32-bit, Debian 9.2 x86_64, Android 7.0 on Samsung Galaxy S7, ...)
Attach a save game if possible
If this bug only occurred recently, please note the last version without the bug, and the first version including the bug. That way we can fix it quicker by looking at the changes made.
Next, select the game in the 'Game' dropdown, and the game engine or other component in the 'Component' dropdown. Enter your text, and hit the button!

comment:2 by alxpnv, 5 months ago

Owner: set to alxpnv
Resolution: assigned
Status: newpending

by George22x, 5 months ago

comment:3 by George22x, 5 months ago

Windows 10 Home, 21H1. It was in ScummVM 2.6.0git1749 and is still in the latest development build. I attached a video clip.

Last edited 5 months ago by George22x (previous) (diff)

comment:4 by digitall, 5 months ago

George22x: Thanks for providing this detail. I think alxpnv will likely look at this in due course.

comment:5 by George22x, 5 months ago

UPDATE: This is a similar issue as the closed bug #13108. In my case it is flicker free with SDL without a scaler and flickers with it, while with OpenGL it flickers both with and without scaling. I tested it with HQ scaler.

Last edited 5 months ago by George22x (previous) (diff)

in reply to:  5 comment:6 by alxpnv, 5 months ago

Replying to George22x:

UPDATE: This is a similar issue as the closed bug #13108. In my case it is flicker free with SDL without a scaler and flickers with it, while with OpenGL it flickers both with and without scaling. I tested it with HQ scaler.

Can you provide a screenshot of the Graphics tab?

by George22x, 5 months ago

Attachment: 1.jpg added

by George22x, 5 months ago

Attachment: 2.jpg added

by George22x, 5 months ago

Attachment: 3.jpg added

by George22x, 5 months ago

Attachment: 4.jpg added

comment:7 by George22x, 5 months ago

I took 4 screenshots of graphics settings. 1 is flicker free, while 2-4 are flickering and also these thumbnails are rather tiny and hard to discern.

Note: See TracTickets for help on using tickets.