Opened 7 months ago

Closed 6 months ago

#13138 closed defect (fixed)

On-screen keyboard doesn't work on Android Runtime for Chrome OS

Reported by: mherberg Owned by: mduggan
Priority: normal Component: Port: Android
Version: Keywords: scummvm android chromeos keyboard
Cc: mherberg Game:

Description

ScummVM version: 2.5.0
Bug details: On-screen keyboard control does not load when clicking/touching in Android Runtime for Chrome (ARC).
My OS: Android 9 Build R94-14150.87.0 in Chrome OS 94.0.4606.124 (32-bit)

Change History (3)

comment:1 by mduggan, 7 months ago

Not showing the soft keyboard when a hardware keyboard is available is by design. The code checks if one is available:
https://github.com/scummvm/scummvm/blob/master/backends/platform/android/org/scummvm/scummvm/ScummVMActivity.java#L503

However, I see that isHWKeyboardConnected() is not quite right for tablet mode (when you flip the keyboard around to use a Chromebook as a tablet device). It's only checking for a keyboard existing, not if it is hidden. When a Chromebook is in tablet mode it should return hardKeyboardHidden == HARDKEYBOARDHIDDEN_YES.

Ideally the soft keyboard button should also be hidden while the hardware keyboard is usable. I'll try to make a PR to fix both of those

comment:2 by mherberg, 7 months ago

Thank you. I should have clarified that I am using a Chrome OS tablet. Happy to test any changes.

comment:3 by mduggan, 6 months ago

Owner: set to mduggan
Resolution: fixed
Status: newclosed

Sorry for the slow update, I made a PR but then forgot to follow up on it. This was fixed in 53c22e4 and should be available in the next nightly. Please give it a test and if it's all good it will be included in the next play store release.

Note: See TracTickets for help on using tickets.