Opened 6 months ago

Last modified 6 months ago

#13132 new defect

TWINE: LBA1 GOG version Adeline jingle does not play at all

Reported by: antoniou79 Owned by:
Priority: normal Component: Engine: TwinE
Version: Keywords: jingle, GOG, midi
Cc: Game: Little Big Adventure

Description

This is on Windows 10x64, with current daily build (64bit), and also tested with ScummVM 2.5.0 release, and a local build from master (msys2/mingw-64) with release configuration. The issue occurs for the GOG version of the game (Tested with English installation).

The jingle (midi track 31) is not heard at all during the intro (immediately when launching the game). The game does not output any error for this, in fact, it seems that the game "thinks" that the midi is being played normally (but no sound is heard).

Some things I've tried:

  • I forced the game to load another midi track there (by changing the code in screens.c, re-building and running). The track played fine.
  • I added a play_midi debugger command, and forced the 31 track to play when the game starts proper (at the prison cell map). The track played fine.
  • I tested with the Steam release (detected as dotemu enhanced version and their "midi" track plays fine -- the midi track in this case is an mp3 version of a midi track of the jingle)

So it's a weird issue, specific to GOG release, and specific to 31 track playing at the logo in particular (because it plays normally elsewhere).

The fade-in for this Adeleine logo seems a lot faster too, compared to how the game runs with the DosBox configuration that GOG officially sets up.

Note (informational): The GOG version works with DosBox. They put the VOX folder with files for the supported localizations into the game installation folder, but the FLA folder is missing. That is because, GOG using DosBox, mounts a Cue/Bin CD image in mixed mode (because it is an audio CD too), and the FLA folder is in that image.

Change History (4)

comment:1 by antoniou79, 6 months ago

Summary: TWINE: LBA1 GOG version Adeleine jingle does not play at allTWINE: LBA1 GOG version Adeline jingle does not play at all

comment:2 by vvs-, 6 months ago

There is only a single file difference between GOG and CD version (LBA_GRI.HQR) and it's not related to music at all. In fact, extracting all the files from LBA.GOG you'll get it detected as CD. So it's not specific to GOG.

I have the same problem with CD version if I'm using default ScummVM settings. But just changing MIDI to Fluidsynth fixed it for good.

comment:3 by antoniou79, 6 months ago

Right, sorry I should have specified. I only own the GOG version and the Steam version of the game. I do not have access to any original boxed copy of the game, so I couldn't know if it happened there as well.

Also, setting Midi to FluidSynth fixes the jingle issue indeed. I still think that it's a bug worth investigating, because it seems so weird (other midi tracks play, and there's seemingly nothing wrong with the 31st track as it can play elsewhere). But good to know there's a workaround.

comment:4 by mgerhardy, 6 months ago

Keywords: midi added
Note: See TracTickets for help on using tickets.