Opened 6 months ago

Closed 5 months ago

#13126 closed defect (fixed)

GRIM: Grim Fandango opengl savescreen blanking

Reported by: arrowgent Owned by: aquadran
Priority: low Component: Engine: Grim
Version: Keywords: grim, opengl, linux, save, menu, 2.5.0
Cc: Game: Grim Fandango

Description

Please check you are including all the following information in your bug report:

ScummVM version (scummvm -v)
ScummVM 2.5.0 (Dec 1 2021 22:52:30)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ sndio TiMidity RGB zLib MPEG2 FluidSynth Theora AAC A/52 FreeType2 FriBiDi JPEG PNG GIF TTS cloud (servers, local) TinyGL OpenGL (with shaders) GLEW
-- aquired from a PPA which compiled this version.
https://launchpad.net/~savoury1/+archive/ubuntu/games/+index?field.series_filter=bionic

Bug details, including step-by-step instructions to reproduce the bug
start game, exit door.

save game in opengl/opengl with shaders
menu becomes black
softare mode does not have this error

Language of game (English, German, ...)
english

Version of game (CD, Floppy, DOS, Amiga, ...)
CD + patch 1.01

Your OS, including version and device if appropriate (Windows 10 build 1709 32-bit, Debian 9.2 x86_64, Android 7.0 on Samsung Galaxy S7, ...)
Linux Ubuntu 18.04 LTS x86_64
Nvidia 1070 Driver Version: 470.86

Attach a save game if possible
not required

If this bug only occurred recently, please note the last version without the bug, and the first version including the bug. That way we can fix it quicker by looking at the changes made.
new release v2.5.0

Next, select the game in the 'Game' dropdown, and the game engine or other component in the 'Component' dropdown. Enter your text, and hit the button!
yep.

screenshots:

enter empty save
https://i.imgur.com/WPlwVze.png
then black screen
https://i.imgur.com/uwghl5C.png

Change History (7)

comment:1 by arrowgent, 6 months ago

Keywords: opengl linux 2.5.0 added; 2.5 removed

comment:2 by eriktorbjorn, 6 months ago

This sounds like a duplicate of https://bugs.scummvm.org/ticket/12936 in which case it should already be fixed. Could you try it with a nightly build?

comment:3 by arrowgent, 6 months ago

https://github.com/scummvm/scummvm/commit/51edb558512b936382a805121dec0b651575f70c

hmmm
this was commited oct 1st, before v2.5.0 release
so this should already be in the stable release?
depending if it was branched from a different release branch

it does appear related obviously:

glClearColor(0, 0, 0, 1.0f);
opengl issue, black screen ...

comment:4 by eriktorbjorn, 6 months ago

From what I understand, 2.5.0 was tagged on October 1st, before that bugfix was made. (And the 2.5 branch would have happened some time before that. I forget exactly when.) The release date was on October 9th, but that delay was probably to prepare downloads for various systems.

So it should work in the nightly build, and in the upcoming 2.5.1. But not in 2.5.0.

Last edited 6 months ago by eriktorbjorn (previous) (diff)

comment:5 by arrowgent, 6 months ago

great. until the release comes out for ubuntu 18.04 i will wait
i doubt the debian nightly will work
i could compile the build myself ... i compile enough software
not really in the mood honestly

but i will retest when v2.5.x does release.
thanks for your reply and clarification

comment:6 by arrowgent, 5 months ago

seems like it was fixed

2.5.1 "Californium" (2022-01-02)
Fixed black screen while entering save game name.
OpenGL without shaders is preferred as default for Grim Fandango.

comment:7 by bluegr, 5 months ago

Owner: set to aquadran
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.