Opened 6 months ago

Closed 6 months ago

Last modified 4 months ago

#13111 closed defect (fixed)

Crash during load of saved game in Freddi Fish 1

Reported by: kamaradclimber Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Version: Keywords: freddi load
Cc: kamaradclimber Game: Freddi Fish 1

Description

When using scummvm 2.5.0 on Linux, loading of saved games in Freddi Fish 1 crashes the VM with:

WARNING: Unrecognized base tag 0x524d4948 in sound 1!
scummvm: engines/scumm/resource.cpp:741: int Scumm::ScummEngine::getResourceSize(Scumm::ResType, Scumm::ResId): Assertion `ptr' failed.
Aborted (core dumped)

To reproduce (systematic):

  • launch the game
  • skip all the cut scenes with Esc
  • load a game with "l" shortcut and select a saved game

Scenario that does not reproduce the bug (at least not on my tests):

  • launch the game
  • wait cut scenes to finish
  • load a game with "l" shortcut and select a saved game

Change History (5)

comment:1 by eriktorbjorn, 6 months ago

I had trouble figuring out how to reproduce this, but it's almost certainly the same problem as described in https://bugs.scummvm.org/ticket/13113

Since I just fixed that one, this one too should be fixed in the next nightly build and in the upcoming 2.5.1. If that's not the case, please let me know.

comment:2 by eriktorbjorn, 6 months ago

Component: --Unset--Engine: SCUMM
Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:3 by kamaradclimber, 6 months ago

Thank you, I'll check once the 2.5.1 has been released for my distribution.

comment:4 by eriktorbjorn, 6 months ago

Ok, thanks. I don't know when 2.5.1 will be released, though. (A little bird told me a while ago that it might not be that far away, but at least one more game-breaking bug in a different game engine has been found since then, and the jury is still out on how to fix that one properly...)

comment:5 by kamaradclimber, 4 months ago

I can confirm it is fully fixed for freddy fish1. Thanks!

Note: See TracTickets for help on using tickets.