Opened 7 months ago

Closed 7 months ago

#13105 closed defect (fixed)

SCUMM: HE - Crash when loading certain save games

Reported by: raziel- Owned by: eriktorbjorn
Priority: normal Component: Cloud
Version: Keywords:
Cc: Game: Freddi Fish 4

Description (last modified by raziel-)

ScummVM 2.6.0git (Nov 24 2021 10:38:39)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC A/52 FreeType2 FriBiDi JPEG PNG GIF cloud (servers, local) TinyGL OpenGL

I get a crash (see crashlog) on AmigaOS4 and Windows32 when
immediately loading a game *while* the save game syncing is still in progess (cloud icon pulsating).

This is rather hard to reproduce on a fast system, but it is doable.
loading certain save games in Freddi Fish 4.

1) Start the game
2) Cancel all cutscenes
3) Press "l"
4) Load any save game from way in the game (it doesn't trigger if you load a save state that is at the start screen, at least, i couldn't trigger it with such a save)

  • AmigaOS4 will crash in OpenSSL, crypto, while
  • Windows32 will simply quit silently without anything meaningful in the console/log

Freddie Fish 4: The Hogfish Rustlers of Briny Gulch (Windows/English)

This was confirmed on Windows32, same game, same cloud account

AmigaOS4 - PPC - SDL - BE
gcc (adtools build 11.1.0) 11.1.0

Attachments (4)

Crashlog_ScummVM_2021-11-26_09-43-58.txt (39.4 KB ) - added by raziel- 7 months ago.
Win32.log (1.3 KB ) - added by raziel- 7 months ago.
amigaos4.log (666 bytes ) - added by raziel- 7 months ago.
freddi4-win-us-Freddi4.sgb (27.9 KB ) - added by raziel- 7 months ago.

Download all attachments as: .zip

Change History (7)

by raziel-, 7 months ago

Attachment: Win32.log added

by raziel-, 7 months ago

Attachment: amigaos4.log added

by raziel-, 7 months ago

Attachment: freddi4-win-us-Freddi4.sgb added

comment:1 by raziel-, 7 months ago

I can trigger it with the attached savegame under windows

comment:2 by Satertek, 7 months ago

I'm seeing what I believe may be the same issue but I am not using any cloud features. See #13113

comment:3 by raziel-, 7 months ago

Description: modified (diff)
Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed
Summary: CLOUD: Crash when loading a game while snycing is in progressSCUMM: HE - Crash when loading certain save games

@Satertek

You are quite right.
I was hooked on the cloud feature since i got the crash log which points me there (even with cloud/sync disabled), but it seems my platforms crash logs are far from useful.

Closing and relabeling this in favour of your bug report.

Note: See TracTickets for help on using tickets.